Page MenuHome

Collada Cannot Import
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card

Windows 7 Ultimate 64-bit, Intel HD 3000

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
2.7
Worked: (optional)

Short description of error
Collada Import process is so slow. And sometimes impossible.
I attached example file. I imported in 3dsmax, only 15-20 seconds, but in Blender
cannot import after 20 minutes, and still waiting... Collada is unique animation
transfer format in Blender, so most important for me (and for most peoples).

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Details

Type
Bug

Event Timeline

Hikmet Koyuncu (spiderh) set Type to Bug.
Hikmet Koyuncu (spiderh) created this task.
Hikmet Koyuncu (spiderh) claimed this task.
Hikmet Koyuncu (spiderh) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) triaged this task as Normal priority.

Gaia, care to check? Thanks! :)

Hikmet, I don't know if this may help .. but have you tried to load your model in Autodesk FBX Viewer ?

I did it and your scene seems quite strange, see the picture below. Is it on purpose ? I mean, is it the intended appearence your scene should have ?

If the FBX Viewer itself can't read the scene correctly then I doubt Blender can. This could be a sort of "proof test" you could use to test your exports before passing them to Blender.

No, I imported in 3dsmax 2013 and didn't seem problem, because I used OpenCollada plugin. FBX Viewer cannot read OpenCollada format very well.

Hikmet,

I tested your scene against the official collada coherency test. It reports a series of errors, I extracted some of them for your reference.

Unfortunately the fact that Max reads the scene does not mean that it is good for other applications to read. This is what I was trying to tell in my previous post. You should check your exports against a reference viewer to see if it is good or not. Since afaik there's not such a viewer around, the Autodesk viewer seems a decent choice. Also, the coherency test is useful to check if your export works well.

For example, from what I can understand from the last error reports, you have absolute paths for the textures, so they can't be found in any other platform apart your own. This is a typical export error you should check for.

For the sake of completeness, I would add that none of the reported errors in the scene seems critical, so a good importer may be able to handle them anyway. But checking your exports is always a good thing.

Hope this helps. Bye :)

http://collada.org/public_forum/showthread.php/434-coherency-test-available

ERROR: CHECK_schema Error msg=Element '{http://www.collada.org/2005/11/COLLADASchema}texture', attribute 'texcoord': '' is not a valid value of the atomic type 'xs:NCName'.
ERROR: CHECK_schema Error msg=Element '{http://www.collada.org/2005/11/COLLADASchema}source', attribute 'name': '0000_object00Pos' is not a valid value of the atomic type 'xs:NCName'.
ERROR: CHECK_schema Error msg=Element '{http://www.collada.org/2005/11/COLLADASchema}source', attribute 'name': '0000_object00Nrm' is not a valid value of the atomic type 'xs:NCName'.
ERROR: CHECK_schema Error msg=Element '{http://www.collada.org/2005/11/COLLADASchema}source', attribute 'name': '0000_object00UV' is not a valid value of the atomic type 'xs:NCName'.
ERROR: CHECK_file failed, file:/E:/Programlar%20-%20Duzenlenmis/Game%20Programs/Tools/_General/3D%20Programs/Noesis%204.0972/Program/Package/ffx0000 not found
ERROR: CHECK_file failed, file:/E:/Programlar%20-%20Duzenlenmis/Game%20Programs/Tools/_General/3D%20Programs/Noesis%204.0972/Program/Package/ffx0001 not found

Thanks for reply padone.

I'm use OpenCollada plugin for 3dsmax: https://collada.org/mediawiki/index.php/OpenCOLLADA

Exporter don't export texture data very well, but animation data exported perfect. I retextured model after import. I'm use same exporter for small files and Blender import this files, but very slowly. If animation data a bit long, then cannot import (wait for long long time).

Problem is Blender's Collada importer very very slow. Source code must check and optimize.

@Hikmet Koyuncu (spiderh), could you attach some screenshots of how it should look like? And if possible a rendered animation would help too, so end result in Blender, when fixed, can be verified.

Hi!

Here are example Collada file (633 frame, It took 40 seconds for import).

And screenshots:

x100 scale, rotate 180 degree on X axis.

x400 scale, rotate 180 degree on X axis.

x400 scale, rotate 180 degree on X axis. Fix Materials (Alpha, Specular etc...)

My first uploaded DAE files is 8909 frame.

Here, open same Collada file on Noesis 3D Screenshot (Export from this program. First DAE. 8909 frame)

Here, this is 3dsMax screenshot (First DAE, 8909 frame, It took 35 seconds for import. No fix material.):

Sergey Sharybin (sergey) closed this task as Archived.

jesty, i'm totally fine if you gonna to improve collada, but in the bug tracker we only keep reports we can tackle in reaosnable time. So IMO it's better to keep collada in own wiki page (http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Import_Export#Import:_Bugs in this case).

You'll be very welcome to fix issues, but if we accept bug reports here you need to become an official maintainer, meaning fixing like at least bug per week ;)