Page MenuHome

Copy Rotation Constraint - options "Invert" and "Offset" conflicts with each other
Closed, ArchivedPublic

Description

System Information
Kubuntu Linux 13.04 64bit, AMD Radeon HD 4670 graphics

Blender Version
Broken: tested in 2.70 official release (2014-03-19, hash 19e627c), 2.68a, 2.61
Worked: n/a

Short description of error
"Offset" option (as I think) means that Copy Rotation Constraint
permits user rotating that bone. But this not always the case.

When Copy Rotation Constraint has partial (not 0 and not 1) influence,
constraint options "Invert" and "Offset" conflicts with each other -
causes two bad effects: unachievable angles
and flipping direction of rotation.

Exact steps for others to reproduce the error
See attached *.blend file (this text is dublicated in blend-file).

Bug 1. Bone has vast "dead", not achievable ranges. Try rotating
the Blue bone by R->X->X - it is impossible to make
bone travel full circle.
For comparison, try to make the same with the Green bone -
that is okay and easily makes full circle. The only difference
between them is flag "Invert" in constraint.

The Red bone even almost "paralyzed" by setup of its
Copy Rotation Constraint: Influence = 0.5.

Bug 2. All bones have the same orientation and roll.
Select Red, Blue And Green Bone. Try rotating them by hitting R->X->X.
Bones rotates in different directions or not rotates at all
depending on Copy Rotation Constraint setup.

Details

Type
Bug

Event Timeline

Aleksander Tarkhanov (stark) raised the priority of this task from to Needs Triage by Developer.
Aleksander Tarkhanov (stark) updated the task description. (Show Details)

Even confirmed, considering that a very low priority report, because usually workaround is very simple: just not to use "Offset" and "Invert" together - just change roll by 180 deg. for one of interacting bones.

Will have a look, but perhaps the answer would be -- design limitation, could be re-cosidered but that'd be a TODO.

Sergey Sharybin (sergey) lowered the priority of this task from Needs Triage by Developer to Normal.Apr 11 2014, 8:50 AM
Bastien Montagne (mont29) closed this task as Archived.May 21 2014, 4:06 PM

Yeah, these are no bugs, not even TODOs, these are just limitations due to how constraints work currently… They are highly limited, esp. regarding rotations, and hacks like offset & co only makes thing more complicated.

Thanks for the report, but will close it a “just not solvable”, a full redesign of constraints (among other things) is planned in some future anyway.

O.K. than, thanks for your attention to that report, Sergey and Bastien. You never know in advance what is designed to work well and what is just a "hack" or so.