Page MenuHome

Quick keyboard buttons pressing does not work
Closed, ArchivedPublic

Description

System Information
Linux Mint Olivia x64

Blender Version
Broken: 2.70
Worked: 2.67

Short description of error
That is not error itself, but a little bug maybe.
It was possible in 2.67 to quickly perform some operations, like scaling vertexes to zero, by quickly press S -> 0 -> Enter. In fact, it took less then half a second on keyboard. It could be pressed so fast, that left hand is still pressing (did not release) the S button, and right hand is already pressing the 0 on numpad. In the latest versions, blender ignores pressing 0 while the S is still pressed. It disturbs and makes user to concentrate not on working, but on pressing and releasing buttons :)

Exact steps for others to reproduce the error
See the description.

Details

Type
Bug

Event Timeline

Maxim Tkachenko (maleficmax) created this task.
Maxim Tkachenko (maleficmax) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) closed this task as Archived.Mar 26 2014, 7:35 PM
Bastien Montagne (mont29) claimed this task.

This is indeed not a bug… Issue is, supporting such kind of "quick press" generates other issues - handling keyboard events is rather tricky. Thanks for the report anyway. :)