Page MenuHome

"Limit Scale" Constraint allows zero and inverse values
Closed, ArchivedPublic

Description

Version 2.70 official (win 64)

How to reproduce:

  • Open provided file, inspect Suzanne's "Limit Scale" constraint, and scale Suzanne.
  • Notice that Suzanne can still be inverted to -1.0 XYZ values, even though this should not be allowed.

This bug persists whether it is evaluated in world space or local, and whether or not the "for transform" box is checked. You can also manually enter "0" for Suzanne's scale values and this will pass through the constraint as well.

Unrelated nitpicking: why are the default values for this constraint 0.0? They should all be 1.0, or 0 to 1.0.

Details

Type
Bug

Event Timeline

Sam Brubaker (rocketman) set Type to Bug.
Sam Brubaker (rocketman) created this task.
Sam Brubaker (rocketman) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) closed this task as Archived.Mar 28 2014, 6:02 PM
Bastien Montagne (mont29) claimed this task.

Unfortunately, those issues are due to the fact that constraints only get a matrix to work on. And you cannot extract the whole sizing data from a matrix (to be exact, negative scale in a matrix are expressed as rotations transforms, and you cannot extract anything from a null-scale matrix).

So these are internal limitations, not bugs. Thanks for the report, anyway! :)