Page MenuHome

Inverse Kinematics bone constraint (and AutoIK) ignores bone rotation limits
Closed, InvalidPublic

Description

System Information
Windows 7 64-bit
GeForce 430

Blender Version
Broken: 2.68a
Worked:?

Short description of error
Both "Inverse Kinematics" bone constraint and AutoIK ignore bone rotation limits.

Exact steps for others to reproduce the error
Rotate the bone manually, and z rotation will only go from 0 to 90, but turn on AutoIK and it will ignore the rotation limits. The same will occur if you unhide the Inverse Kinematics bone constraint that I added, then move the Circle toward the hips.

Details

Type
Bug

Event Timeline

Jacob Gustafson (mixmystery) created this task.
Jacob Gustafson (mixmystery) raised the priority of this task from to Needs Triage by Developer.

I don't believe this is valid.

You must limit the rotation of bones in a IK chain using the IK settings in the bone properties, not in the constraints.

Here are the settings you're looking for. You left these untouched!

Joshua Leung (aligorith) closed this task as Invalid.Apr 2 2014, 1:35 AM
Joshua Leung (aligorith) claimed this task.

Not a bug, as @Sam Brubaker (rocketman) has said.