Page MenuHome

VSE Strips: Driver values not recognized during render
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card
Win 7 AMD HD7470

Blender Version
Broken: 2.70 #b66a954
Worked: None I could find

Short description of error

Any VSE strips that have drivers attached to values, play driver animation ok. But the same driver animation fails at render time.

Exact steps for others to reproduce the error

  1. Add a strip of audio or video or still image and attach a driver to a scene object.
  2. Animate the object with keyframes.
  3. Render out animation.

The animation does not get baked into animation drivers.

I have attached a .blend with an audio strip as an example.

Details

Type
Bug

Event Timeline

david mcsween (davidmcsween) created this task.
david mcsween (davidmcsween) raised the priority of this task from to Needs Triage by Developer.

Sorry here is the .blend file. I accidentally added the clean audio in the task. This file has the audio packed in.

Sorry I see now that there is an item number for this problem https://developer.blender.org/T39697

Strangely a search did not turn this up earlier. Also my problem is not using a "frame" call.

Bastien Montagne (mont29) triaged this task as Normal priority.

Joshua, I’ll let you decide whether to merge or not. :)

Merged T39697 into this one, since this one seems to refer more to the generic issue here than the other one does.

@Joshua Leung (aligorith), shall we consider this a bug or a TODO for the ongoing depsgraph project?

Poking @Joshua Leung (aligorith) again ;). If we don't get a decision, I'll go ahead and close this as a todo.

Sergey Sharybin (sergey) closed this task as Archived.May 26 2015, 6:36 PM

I'd consider this a TODO related to the depsgraph refactor project now. It'll be easier to support such situations there,