Page MenuHome

Collada Export writes Material Alpha Chanel data, but does not reads it
Closed, ArchivedPublic

Description

System Information
(does not apply: Win8)

Blender Version
Broken: 2.10 19e627c
Worked: unknonw

Short description of error
Animation data for Material Alpha value is exported to DAE, but not imported by blender.

Exact steps for others to reproduce the error

  1. Start a new project (with cube).
  2. Switch to the cube material tab.
  3. Select "Transparency"
  4. Set Keyframe for "Alpha"
  5. Change Frame
  6. Set new value for "Transparency"
  7. Set new keyframe
  8. Export project to Collada-File (.dae) with default settings

(in the dae exported, the Alpha-Value-Animation is written)

  1. Start a new project and delete the automatically generated cube
  2. Import the dea-file created in step 8

--> No animation data is imported.

BTW: Thanks for the really great programm you created!

Details

Type
Bug

Event Timeline

Jörg (GrumpyOldMan) raised the priority of this task from to Needs Triage by Developer.
Jörg (GrumpyOldMan) updated the task description. (Show Details)
Jörg (GrumpyOldMan) set Type to Bug.

Gaia, I assign it to you, not sure whether you’d consider this as supported or unsupported part of Collada currently. If the later, feel free to mark as TODO and close.

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Normal.Apr 23 2014, 4:55 PM
Bastien Montagne (mont29) closed this task as Archived.Apr 25 2014, 6:16 PM

We are sorry, but we currently have no maintainer for Collada area, and there is no point in keeping opened reports that no one will tackle any time soon.

We only intend to maintain basic support for SecondLife export, but it is very unlikely to get any more real work done here (even the OpenCollada library we use in Blender is a rather… quite project since some time now).

Sergey Sharybin (sergey) closed this task as Archived.May 29 2014, 10:33 AM

Bug tracker is for reports which are gonna to be tackled in a reasonable amount of time. Not sure how much Jesty is available for this, would be fine if he can tackle this but IMO it's more like a TODO http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Import_Export#Export:_missing_features_or_not_a_Collada_issue