Page MenuHome

Collada Import - Bone Duplication
Closed, ArchivedPublic

Description

OS: Windows 7 X64

Version Info:
V2.61 & 2.62: No triplicates, only parameters in animation = rotation in a Euler format, animation plays upside down, only 237 frames of animation
V2.63 & 2.66: Triplicates, parameters in animation =rotation(quaternion), location and scale, animation plays OK but only 237 frames of animation
V2.69 & V2.70: Triplicates, parameters in animation =rotation(quaternion), location and scale, animation plays OK with 296 frames of animation

Issue:
Collada import is creating 3 copies of the bones in an animation file. Format is openCollada 1.4.1 (https://github.com/KhronosGroup/OpenCOLLADA/wiki/OpenCOLLADA-Tools) Exported from 3DS Max 2013. Autodesk Collada doesn't load at all.

Reproduction:
Import an openCollada 1.4.1 DAE file using the Collada Importer. Blend scene and openCollada 1.4.1 file created from 3DS Max.

Files:
Collada DAE file
Blend Scene
http://www.diviniaro.com/files/Collada_Tripple_Bones.zip

Details

Type
Bug

Event Timeline

Bryan Conn (reddozen) raised the priority of this task from to Needs Triage by Developer.
Bryan Conn (reddozen) updated the task description. (Show Details)
Bryan Conn (reddozen) set Type to Bug.
Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Normal.

Another one on your plate, Ô King Jester! :)

Note that the number of key frames in the older versions was due to a set FPS of 24. This was corrected to 30 already. This bug revolves around the fact that the WXYZ values are getting duplicated in the import on the dope sheet and show up as additional bones on our game engine exporter.

Sergey Sharybin (sergey) closed this task as Archived.May 29 2014, 10:50 AM

Moving to TODO http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Import_Export#Import:_Bugs Bugtracker is for reports we can handle in reasonable amount of time.