Page MenuHome

Loop Cut in Vertex select mode automatically switches to Edge select mode
Closed, InvalidPublic

Description

System Information
Win7 64bit
GeForce 750M

Blender Version
Broken: 2.70 517094a TestBuild2
Worked: 2.70a f93bc76 Official Release

Short description of error
Blender automatically switches to Edge select mode when using Loop Cut with more than one loop. In older versions it stayed in vertex select mode as expected.

Exact steps for others to reproduce the error
In edit mode:
Switch to vertex select mode,
Activate loop cut and slide (Ctrl+R)
turn the mouse wheel to make two (or more) loops at once
confirm and blender automatically switches to edge select mode

Details

Type
Bug

Event Timeline

Marek Moravec (marek) updated the task description. (Show Details)
Marek Moravec (marek) raised the priority of this task from to Needs Triage by Developer.
Marek Moravec (marek) set Type to Bug.

Hi Marek,
yesterday I did the same report but it is now closed.

Campbell as you can see this is an annoying behaviour, please bring the old behaviour. Because when one is working with vertex, he doesn't want that Blender switches to edge just like that.

I hadn't noticed the previous report, sorry for opening a new one. However I think that if the tool does not work as expected it is a bug. Can't see a reason in bringing more inconsistency into this tool.

I was coming to report a bug on this too.
I agree this is annoying behaviour and not expected. Prefer that Blender doesn't automatically change selection mode just from using a commonly used tool. User uses chooses their selection modes for a reason.

Old version would switch to edge mode to cleanly slide, then back to the mode you were using previously right after confirming the action,

Bastien Montagne (mont29) claimed this task.

Guys, please! This is not a bug, it works as intended. If you think that behavior is wrong, then please open a discussion on a forum or on bf-funboard ML, but there is no place on our tracker for such things.

I was going to submit a bug report about this, but found that there are already several similar reports were made but closed as invalid. I agree with others that this is annoying and unexpected behavior during workflow, but as you ask I am not going to argue with that here. OK, you say it works as intended, but then why does it change the selection mode only when number of cuts is more than one? (If you do a loopcut with just one cut it still stays in vertex mode). This is quite inconsistent. Is it also intended?