Page MenuHome

Volume Scattering inside Glass Material = Noisy Mess
Closed, InvalidPublic

Description

System Information
osx 10.9.3

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
Worked: (optional)

Short description of error
Volume Scattering inside Glass Material not possible to Render without heavy Noise, even with 100'000 Samples.

1024 Samples each, Point Light

Volume Scattering only

Glass Only

Glass + Volume Scattering

Glass + Volume Scattering (but Glass Shadow Pass set as Transparent)

Exact steps for others to reproduce the error
Open .blend File
There are 4 Node Frames for each Setup used in Sample Images (1-4)

Details

Type
Bug

Event Timeline

Volume Sampling is still missing some optimizations, and the Glass + Scatter example is just something that is difficult for a Unidirectional pathtracer. CC'ing @Brecht Van Lommel (brecht) here, but pretty sure there is no bug.

Thomas Dinges (dingto) closed this task as Invalid.
Thomas Dinges (dingto) claimed this task.

I did think it could be something like this. I just was not sure where i'd have to go to make sure it's on the to do list.

The Reason why i think it could be a Bug is the Result i get "Glass + Volume Scattering (but Glass Shadow Pass set as Transparent)", cause the Result is much brighter than it imo should be.

I'm sure Volume Light Path is on the ToDo List?