Page MenuHome

Rigid body problem within inner mesh?
Closed, InvalidPublic

Description

Click animation in Blender no information needed to explaine :}

Details

Type
Bug

Event Timeline

Iwaniuk (mariuszi28cg) raised the priority of this task from to Needs Triage by Developer.
Iwaniuk (mariuszi28cg) updated the task description. (Show Details)
Iwaniuk (mariuszi28cg) set Type to Bug.

I have done the windmill project, but during the animation is extracted from the axis.See attached file. :P

I did the animation and the second problem is that the cylinder should go inside, and it is not. Maybe this is not a problem but there is no implementation yet, shame.

I use Blender 2.70a hash f936c76 2014-04-10 11:49, windows 8.1

Sergej Reich (sergof) closed this task as Invalid.Jun 14 2014, 7:46 PM
Sergej Reich (sergof) claimed this task.

Thanks for the report, but this is not a bug.
You're assigning convex hull shapes to non-convex objects (pretty much all objects in the files are concave).
What you need to do is either split the objects into convex parts, or use mesh shapes. Mesh shapes are not very stable of course to it'll be hit or miss.
In general, if you want to do things like having objects rotate about a specific axis, it's much better to use constraints.

Thanks for the explanation.