Page MenuHome

two linked 'Child of - constraint' causes object to jump at 180 degree rotation
Closed, ArchivedPublic

Description

System Information
Ubuntu 14.04

Blender Version
Broken: 2.71 RC, 169c95b

Short description of error
If at least three objects are linked by two child of constraints, where the second constraint influence is set to 0.5 (not 1) the third object jump after 180 degree rotation

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

  1. Create three cubes on the x axis.
  2. set first cube to rotate 360 degree
  3. attach child of - constraint to second cube. Target first cube. Set influence to 0.5
  4. attach child of - constraint to third cube. Target second cube. Influence 1.0

You will see that the third cube jump when the first cube has rotated 180 degrees. The problem is that the second cube orient itself at 180 degrees.

  • Speculation **

The cause of the reason might be how the rotation vector has been defined, that it needs to make 720 degree turn to get back to original position. This might be missed in Child of - constraint.


This is my first bug report. I would like to receive any feedback to learn to report bugs better next time.

Details

Type
Bug

Event Timeline

Henri Seppänen (hoseppan) created this task.
Henri Seppänen (hoseppan) claimed this task.
Henri Seppänen (hoseppan) raised the priority of this task from to Needs Triage by Developer.
Joshua Leung (aligorith) closed this task as Archived.

This is another one of those intractable issues related to matrix decomposition limitations causing issues when trying to blend between the results of different constraints, not to mention the fact that the childof constraint needs to do some fairly evil space-conversion things which don't really play nicely when applied partially.

Closing as a "won't/can't fix" and noted in wiki.

Joshua Leung (aligorith) removed Henri Seppänen (hoseppan) as the assignee of this task.
Joshua Leung (aligorith) triaged this task as Normal priority.