Page MenuHome

SCA Tree Generator adds many objects to Blend file when generating new tree.
Closed, ArchivedPublic

Description

System Information
32-bit Windows XP SP3
2.8 Ghz single core Pentium 4
2 GB RAM
Geforce 6200 256MB

Blender Version
Broken: 2.70, Hash: 19e627c
SCA Tree Generator version 0.2.14

Short description of error
Every time I use "View3D>Add>Mesh>Add Tree to Scene",

Exact steps for others to reproduce the error
Simply use SCA Tree Generator, "View3D>Add>Mesh>Add Tree to Scene", more than once and many leaf/fruit objects, groups, materials, and textures will be unnecessarily added to the blend file, as they are already there the first time you use it, making it very big if it is necessary to add multiple trees or to delete a tree and add another one.

Request radio button to add objects if desired, and if radio button deselected, unlinking all unused objects, groups, materials, and textures so they will be deleted the next time the file is saved and opened.

Thank you for reading.

Details

Type
To Do

Event Timeline

James Russell (Henrymop) set Type to Bug.
James Russell (Henrymop) created this task.
James Russell (Henrymop) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) changed Type from Bug to To Do.Jun 19 2014, 7:43 PM
Bastien Montagne (mont29) triaged this task as Normal priority.

Not a bug, more like a feature request… moved to TODO, up to the author to decide what to do now.

I think you misunderstand. It is a bug because every time I use the addon it makes duplicate object and groups in the blend file, and it makes it really big, like 100MB.

That file has one tree in it. It has about 8 duplicates of each object and group that comes with the addon.

Brendon Murphy (meta-androcto) closed this task as Archived.

closing as archived, tested, cannot reproduce error.