Page MenuHome

Triangle fan bevel behavior
Closed, InvalidPublic

Description

System Information
Windows 7 64Bits

Blender Version
Broken: version 2.71 (sub 0), branch b'master', commit date b'2014-06-18' b'22:46', hash b'b49e6d0', b'Release'
Similar behaviour on 2.71 RC1

Short description of error
Of a triangle fan vertex the bevel/bevel modifier gives undesirable/unexpected behavior

Exact steps for others to reproduce the error
Check screenshot or attached file


Of a vertex where a few edges meet, making a few triangles that form a 90 degree corner the bevel modifier gives a weird effect with a few extra faces{F94833}

Details

Type
To Do

Event Timeline

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Normal.
Howard Trickey (howardt) triaged this task as Confirmed, Low priority.Jun 20 2014, 2:07 PM

This is not a regression; the code is acting as intended according to choices documented in http://wiki.blender.org/index.php/User:Howardt/Bevel .
The "expected results" diagram might be gotten by some combination of the choices "don't preserve angles" and "do partial vertex bevel". I agree that in the case illustrated, the "expected results" look better.

Will have to decide whether to expose more choices to the user, or somehow recognize this as a special case, or leave as is.

I forgot to mention this is probably not a bug per-se, just regular behavior that I thought could use some improvement.
Just to be clear, on the example screenshot the "desirable" or "expected" behavior was hand modeled.

you can dissolve the inner edges of the fan, first. ([del]-key + "Dissolve Edges")
then add the bevel to the object to get the expected result...
i think the bevel algorithm is not able to figure out, what part of the object should be handled in what way - different users, different tastes of what the user expects.

Well that workaround seems to work pretty well, thanks for the tip

Would love to see more options for the bevel modifier. Like those found in C4D R15 . Although that's quite a lot of work I guess.

https://www.youtube.com/watch?v=x5G_EMc0M6Q

Especially that graph part would be cool.

Julian Eisel (Severin) closed this task as Invalid.Mar 17 2015, 2:02 PM

Taking the liberty to close this as todo - there even is a workaround to get the desired result. @Howard Trickey (howardt), hope you're fine with that?

Julian Eisel (Severin) changed Type from Bug to To Do.Mar 17 2015, 2:03 PM