Page MenuHome

"Use Nodes" must be clicked before Volume section appears in menu
Closed, InvalidPublic

Description

System Information
OS X 10.8.5
Processor 2.8 GHz Intel Core i7
Memory 8 GB 1067 MHz DDR3
Graphics ATI Radeon HD 4850 512 MB

Blender Version
Broken: 2.71 ead83a4 and earlier (also confirmed on official 2.70)

Short description of error
Under World Properties there will be no Volume section shown until the user clicks the "Use Nodes" button within the Surface section.
I believe this to be a bug because even if you subsequently un-check "Use Nodes" from the Node Editor it does not go back to the original state where Volume is hidden.
Also there are no other menu sections I know of that are hidden by default.

This caused me considerable confusion while following a video tutorial as to why my Blender menu was different from what was shown.
I ended up testing on multiple versions of Blender, removing settings files, etc before realizing what the problem was.

Exact steps for others to reproduce the error

  1. Start up with the default .blend or a .blend that has never had "Use Nodes" enabled for World.
  2. Choose the Cycles render engine.
  3. Note that in the World Properties there is no "Volume" section shown.
  4. Click the "Use Nodes" button and Volume section appears. Why had it been hidden from us before?

Details

Type
Bug

Event Timeline

Seth L. (quantumanomaly) raised the priority of this task from to Needs Triage by Developer.
Seth L. (quantumanomaly) updated the task description. (Show Details)
Seth L. (quantumanomaly) set Type to Bug.
Thomas Dinges (dingto) closed this task as Invalid.Jun 20 2014, 2:34 PM
Thomas Dinges (dingto) claimed this task.

That is not a bug, before Cycles Nodes (both Surface and Volume) can be used, Nodes must be enabled. This behaviour might change though, once we make Cycles the default engine.