Page MenuHome

Can't build on OSX after some recent commits.
Closed, ResolvedPublic

Description

System Information
OSX 10.8.5, dualXeon 16 threads, ATIHD 5870

Blender Version
Mon morning, june 30, attempt to build
As always

Short description of error
Can't build as always, last successful build was on last friday, then the world cup started again LOL
Exact steps for others to reproduce the error
Including the terminal/ console text.
thanks

Event Timeline

Sergey Sharybin (sergey) closed this task as Archived.EditedJun 30 2014, 11:10 AM
Sergey Sharybin (sergey) claimed this task.

Couple of things:

  • Bug tracker is not the place to report compilation error issues, ML and IRC is more appropriate place for this.
  • It works fine for our OSX platform maintainer @jens verwiebe (jensverwiebe)
  • Pretty much sure you've got something misconfigured in your build_master.sh, because ALL C++ tests are failing.

P.S. without seeing your build_master.sh we can't really help much..

I am not so sure, he says he could build until Friday and cmake fails after openmp.

Then we have this commit b5982f7 which looks suspicious.

Here is the .sh file

I did a bisect and I found that the commit that introduced the problem is 72ac596e19dd

0a0e4e0e698e is working
72ac596e19dd doesn't

a71a8be5cf0b master build failed again.

We tried and it looks like turning off libmv works.

Maybe shared_ptr cannot be detected well in our bundled clang compiler by cmake?

For me all the new detections work with scons and cmake.
I use always the clang-omp for scons builds, did not tested cmake/clang-omp yet.
But i don't see any reason why it should not work with the compiler. ( for it works in scons )
These are boost thingies ..

Jens

version: CMake 2.8-12

It's been a month since I ran the following but now it does fail miserably, it was fine before.

cmake ../blender -DCMAKE_C_COMPILER="/Users/marcclintdion/blender-build/lib/darwin-9.x.universal/clang-omp/bin/clang" -DCMAKE_CXX_COMPILER="/Users/marcclintdion/blender-build/lib/darwin-9.x.universal/clang-omp/bin/clang++" -DWITH_OPENMP=ON

The following are the only successes reported

  • Performing Test SUPPORT_SSE_BUILD - Success
  • SSE Support: detected.
  • Performing Test SUPPORT_SSE2_BUILD
  • Performing Test SUPPORT_SSE2_BUILD - Success
  • SSE2 Support: detected.
  • Performing Test HAVE_STDBOOL_H
  • Performing Test HAVE_STDBOOL_H - Success

EDIT: This output is from running cMake through the terminal.

Just for the record, this is my complete cmake-gui output with specs:

OSX 10.9.4, Xcode 5.1.1, cmake 2.8-9, clang-omp 3.4

The C compiler identification is Clang 3.4.0
The CXX compiler identification is Clang 3.4.0
Check for working C compiler using: Xcode
Check for working C compiler using: Xcode -- works
Detecting C compiler ABI info
Detecting C compiler ABI info - done
Check for working CXX compiler using: Xcode
Check for working CXX compiler using: Xcode -- works
Detecting CXX compiler ABI info
Detecting CXX compiler ABI info - done
Detected system-version: 10.9
Xcode-bundle : /Applications/Xcode.app
Detected Xcode-version: 5.1.1
OSX_SYSROOT_PREFIX: /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform
Performing Test SUPPORT_SSE_BUILD
Performing Test SUPPORT_SSE_BUILD - Success
SSE Support: detected.
Performing Test SUPPORT_SSE2_BUILD
Performing Test SUPPORT_SSE2_BUILD - Success
SSE2 Support: detected.
Performing Test HAVE_STDBOOL_H
Performing Test HAVE_STDBOOL_H - Success
Found OpenAL: /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk/System/Library/Frameworks/OpenAL.framework
Using special OpenMP enabled compiler !
Found OpenGL: /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk/System/Library/Frameworks/OpenGL.framework
Found OpenMP: -fopenmp
Performing Test C_WARN_ALL
Performing Test C_WARN_ALL - Success
Performing Test C_WARN_ERROR_DECLARATION_AFTER_STATEMENT
Performing Test C_WARN_ERROR_DECLARATION_AFTER_STATEMENT - Success
Performing Test C_WARN_ERROR_IMPLICIT_FUNCTION_DECLARATION
Performing Test C_WARN_ERROR_IMPLICIT_FUNCTION_DECLARATION - Success
Performing Test C_WARN_ERROR_RETURN_TYPE
Performing Test C_WARN_ERROR_RETURN_TYPE - Success
Performing Test C_WARN_NO_AUTOLOGICAL_COMPARE
Performing Test C_WARN_NO_AUTOLOGICAL_COMPARE - Success
Performing Test C_WARN_NO_UNKNOWN_PRAGMAS
Performing Test C_WARN_NO_UNKNOWN_PRAGMAS - Success
Performing Test C_WARN_NO_CHAR_SUBSCRIPTS
Performing Test C_WARN_NO_CHAR_SUBSCRIPTS - Success
Performing Test C_WARN_STRICT_PROTOTYPES
Performing Test C_WARN_STRICT_PROTOTYPES - Success
Performing Test C_WARN_MISSING_PROTOTYPES
Performing Test C_WARN_MISSING_PROTOTYPES - Success
Performing Test C_WARN_UNUSED_PARAMETER
Performing Test C_WARN_UNUSED_PARAMETER - Success
Performing Test CXX_WARN_ALL
Performing Test CXX_WARN_ALL - Success
Performing Test CXX_WARN_NO_AUTOLOGICAL_COMPARE
Performing Test CXX_WARN_NO_AUTOLOGICAL_COMPARE - Success
Performing Test CXX_WARN_NO_UNKNOWN_PRAGMAS
Performing Test CXX_WARN_NO_UNKNOWN_PRAGMAS - Success
Performing Test CXX_WARN_NO_CHAR_SUBSCRIPTS
Performing Test CXX_WARN_NO_CHAR_SUBSCRIPTS - Success
Performing Test CXX_WARN_NO_OVERLOADED_VIRTUAL
Performing Test CXX_WARN_NO_OVERLOADED_VIRTUAL - Success
Performing Test CXX_WARN_NO_SIGN_COMPARE
Performing Test CXX_WARN_NO_SIGN_COMPARE - Success
Performing Test CXX_WARN_NO_INVALID_OFFSETOF
Performing Test CXX_WARN_NO_INVALID_OFFSETOF - Success
Performing Test C_WARN_NO_UNUSED_PARAMETER
Performing Test C_WARN_NO_UNUSED_PARAMETER - Success
Performing Test C_WARN_NO_UNUSED_MACROS
Performing Test C_WARN_NO_UNUSED_MACROS - Success
Performing Test C_WARN_NO_MISSING_VARIABLE_DECLARATIONS
Performing Test C_WARN_NO_MISSING_VARIABLE_DECLARATIONS - Success
Performing Test C_WARN_NO_INCOMPAT_PTR_DISCARD_QUAL
Performing Test C_WARN_NO_INCOMPAT_PTR_DISCARD_QUAL - Success
Performing Test C_WARN_NO_UNUSED_FUNCTION
Performing Test C_WARN_NO_UNUSED_FUNCTION - Success
Performing Test C_WARN_NO_INT_TO_VOID_POINTER_CAST
Performing Test C_WARN_NO_INT_TO_VOID_POINTER_CAST - Success
Performing Test C_WARN_NO_MISSING_PROTOTYPES
Performing Test C_WARN_NO_MISSING_PROTOTYPES - Success
Performing Test C_WARN_NO_DUPLICATE_ENUM
Performing Test C_WARN_NO_DUPLICATE_ENUM - Success
Performing Test C_WARN_NO_UNDEF
Performing Test C_WARN_NO_UNDEF - Success
Performing Test C_WARN_NO_MISSING_NORETURN
Performing Test C_WARN_NO_MISSING_NORETURN - Success
Performing Test CXX_WARN_NO_UNUSED_PRIVATE_FIELD
Performing Test CXX_WARN_NO_UNUSED_PRIVATE_FIELD - Success
Performing Test CXX_WARN_NO_CXX11_NARROWING
Performing Test CXX_WARN_NO_CXX11_NARROWING - Success
Performing Test CXX_WARN_NO_NON_VIRTUAL_DTOR
Performing Test CXX_WARN_NO_NON_VIRTUAL_DTOR - Success
Performing Test CXX_WARN_NO_UNUSED_MACROS
Performing Test CXX_WARN_NO_UNUSED_MACROS - Success
Performing Test CXX_WARN_NO_REORDER
Performing Test CXX_WARN_NO_REORDER - Success
CMake Warning at CMakeLists.txt:2264 (message):

'numpy' path could not be found in:


'/Volumes/Workdata/Blender/Development/blender/../lib/darwin-9.x.universal/python/lib/python3.4/python3.4/site-packages/numpy',
'/Volumes/Workdata/Blender/Development/blender/../lib/darwin-9.x.universal/python/lib/python3.4/python3/site-packages/numpy',
'/Volumes/Workdata/Blender/Development/blender/../lib/darwin-9.x.universal/python/lib/python3.4/python3.4/dist-packages/numpy',
'/Volumes/Workdata/Blender/Development/blender/../lib/darwin-9.x.universal/python/lib/python3.4/python3/dist-packages/numpy',
WITH_PYTHON_INSTALL_NUMPY option will be ignored when installing python

Performing Test CXX_HAS_SSE
Performing Test CXX_HAS_SSE - Success
Looking for C++ include memory
Looking for C++ include memory - found
Performing Test HAVE_SHARED_PTR_IN_STD_NAMESPACE
Performing Test HAVE_SHARED_PTR_IN_STD_NAMESPACE - Failed
Performing Test HAVE_SHARED_PTR_IN_TR1_NAMESPACE
Performing Test HAVE_SHARED_PTR_IN_TR1_NAMESPACE - Failed
Looking for C++ include tr1/memory
Looking for C++ include tr1/memory - found
Performing Test HAVE_SHARED_PTR_IN_TR1_NAMESPACE_FROM_TR1_MEMORY_HEADER
Performing Test HAVE_SHARED_PTR_IN_TR1_NAMESPACE_FROM_TR1_MEMORY_HEADER - Success

  • Found shared_ptr in std::tr1 namespace using <tr1/memory> header.

Looking for C++ include unordered_map
Looking for C++ include unordered_map - not found
Looking for C++ include tr1/unordered_map
Looking for C++ include tr1/unordered_map - found
Found unordered_map/set in std::tr1 namespace.
Blender Skipping: (bf_intern_ctr;bf_intern_utfconv;extern_redcode)
Found Git: /usr/bin/git (found version "1.8.5.2 (Apple Git-48)")

  • Found Git: /usr/bin/git

C Compiler: "Clang"
C++ Compiler: "Clang"
HAVE_STDBOOL_H = 1

  • Blender Configuration *

    Build Options:
    • WITH_GAMEENGINE ON
    • WITH_PLAYER OFF
    • WITH_BULLET ON
    • WITH_IK_SOLVER ON
    • WITH_IK_ITASC ON
    • WITH_OPENCOLLADA ON
    • WITH_FFTW3 ON
    • WITH_INTERNATIONAL ON
    • WITH_INPUT_NDOF ON
    • WITH_CYCLES ON
    • WITH_FREESTYLE ON
    • WITH_OPENCOLORIO ON

      Compiler Options:
    • WITH_BUILDINFO ON
    • WITH_OPENMP ON
    • WITH_RAYOPTIMIZATION ON

      System Options:
    • WITH_INSTALL_PORTABLE
    • WITH_X11_XF86VMODE
    • WITH_X11_XINPUT
    • WITH_MEM_JEMALLOC OFF
    • WITH_MEM_VALGRIND OFF
    • WITH_SYSTEM_GLEW OFF
    • WITH_SYSTEM_OPENJPEG OFF

      Image Formats:
    • WITH_OPENIMAGEIO ON
    • WITH_IMAGE_CINEON ON
    • WITH_IMAGE_DDS ON
    • WITH_IMAGE_HDR ON
    • WITH_IMAGE_OPENEXR ON
    • WITH_IMAGE_OPENJPEG ON
    • WITH_IMAGE_REDCODE OFF
    • WITH_IMAGE_TIFF ON

      Audio:
    • WITH_OPENAL ON
    • WITH_SDL ON
    • WITH_JACK OFF
    • WITH_JACK_DYNLOAD
    • WITH_CODEC_AVI ON
    • WITH_CODEC_FFMPEG OFF
    • WITH_CODEC_SNDFILE OFF

      Compression:
    • WITH_LZMA ON
    • WITH_LZO ON

      Python:
    • WITH_PYTHON_INSTALL ON
    • WITH_PYTHON_INSTALL_NUMPY OFF
    • WITH_PYTHON_MODULE OFF
    • WITH_PYTHON_SAFETY OFF
    • WITH_PYTHON_FRAMEWORK OFF

      Modifiers:
    • WITH_MOD_BOOLEAN ON
    • WITH_MOD_REMESH ON
    • WITH_MOD_FLUID ON
    • WITH_MOD_OCEANSIM OFF

      Other:
    • WITH_OPENNL ON

Configuring done
Generating done

Pls. compare eventually differences, try delete cache before configuring.

Jens

Cache is deleted, there's a full build script attached on this bug report too, maybe someone can retry it? (with changes as appropriate for paths of course)

Well, here my configuration,
cd /Volumes/HD_3/blender-src/blender;
git checkout master;
git pull --rebase;
git submodule foreach git pull --rebase origin master;
cd ../lib/darwin-9.x.universal;
svn up;
cd ../../blender-build;
rm CMakeCache.txt;
cmake ../blender -DCMAKE_C_COMPILER="/Volumes/HD_3/blender-src/lib/darwin-9.x.universal/clang-omp/bin/clang" -DCMAKE_CXX_COMPILER="/Volumes/HD_3/blender-src/lib/darwin-9.x.universal/clang-omp/bin/clang++" -DWITH_OPENMP=ON -DWITH_CYCLES_OSL=ON -DWITH_CODEC_FFMPEG=ON -DWITH_MOD_OCEANSIM=ON -DWITH_FFTW3=ON -DWITH_RAYOPTIMIZATION=ON -DWITH_LIBMV=OFF -DWITH_PLAYER=ON;
make install -j16;

this works on master after -DWITH_LIBMV=OFF

All these after…
0a0e4e0e698e is working with -DWITH_LIBMV=ON
72ac596e19dd doesn't

I don't know what else should I post.

Supposing that you keep -DWITH_LIBMV=ON, because I can't find it.
Thanks

Hi
After desperately testing all kinda things, i found that the reason for all tests failing was
due find_package(OpenMP) silently breaking all things.
It should now work fine again with clang-omp from darwin libs and also selfcompiled gcc > 4.6
I assume atm. that a non-apple clang used would be always the one from libs with openmp.

Cheers ... Jens

@Jens (Jens)
After all these new updates
The build under my setup goes well,
However,
-DWITH_LIBMV=OFF
or
-DWITH_LIBMV=ON

the application is not running
It does not hang
it simply does nothing.

Now I can't build blender.

Things getting worse…
Sorry

Sorry, missed this.
Here is the terminal after "successfully" finished the build

/usr/bin/ranlib: file: ../../../lib/libbf_freestyle.a(BaseObject.cpp.o) has no symbols
[100%] Built target bf_freestyle
Undefined symbols for architecture x86_64:

"_omp_get_max_threads", referenced from:
    __ZN11WTURBULENCE18stepTurbulenceFullEfPfS0_S0_Ph in libbf_intern_smoke.a(WTURBULENCE.cpp.o)
    __ZN8FLUID_3D4stepEfPf in libbf_intern_smoke.a(FLUID_3D.cpp.o)
"_omp_get_thread_num", referenced from:
    __ZN11WTURBULENCE18stepTurbulenceFullEfPfS0_S0_Ph in libbf_intern_smoke.a(WTURBULENCE.cpp.o)
    __ZN5ceres8internal26CoordinateDescentMinimizer8MinimizeERKNS0_9Minimizer7OptionsEPdPNS_6Solver7SummaryE in libextern_ceres.a(coordinate_descent_minimizer.cc.o)
    __ZN5ceres8internal16ProgramEvaluatorINS0_23ScratchEvaluatePreparerENS0_27CompressedRowJacobianWriterENS0_21NullJacobianFinalizerEE8EvaluateERKNS0_9Evaluator15EvaluateOptionsEPKdPdSC_SC_PNS0_12SparseMatrixE in libextern_ceres.a(evaluator.cc.o)
    __ZN5ceres8internal16ProgramEvaluatorINS0_23ScratchEvaluatePreparerENS0_34DynamicCompressedRowJacobianWriterENS0_37DynamicCompressedRowJacobianFinalizerEE8EvaluateERKNS0_9Evaluator15EvaluateOptionsEPKdPdSC_SC_PNS0_12SparseMatrixE in libextern_ceres.a(evaluator.cc.o)
    __ZN5ceres8internal16ProgramEvaluatorINS0_21BlockEvaluatePreparerENS0_19BlockJacobianWriterENS0_21NullJacobianFinalizerEE8EvaluateERKNS0_9Evaluator15EvaluateOptionsEPKdPdSC_SC_PNS0_12SparseMatrixE in libextern_ceres.a(evaluator.cc.o)
    __ZN5ceres8internal16ProgramEvaluatorINS0_23ScratchEvaluatePreparerENS0_19DenseJacobianWriterENS0_21NullJacobianFinalizerEE8EvaluateERKNS0_9Evaluator15EvaluateOptionsEPKdPdSC_SC_PNS0_12SparseMatrixE in libextern_ceres.a(evaluator.cc.o)
    __ZN5ceres8internal15SchurEliminatorILin1ELin1ELin1EE9EliminateEPKNS0_17BlockSparseMatrixEPKdS7_PNS0_23BlockRandomAccessMatrixEPd in libextern_ceres.a(schur_eliminator_d_d_d.cc.o)
    ...
"_omp_get_wtime", referenced from:
    __ZN5ceres8internal17WallTimeInSecondsEv in libextern_ceres.a(wall_time.cc.o)
    __ZN5ceres8internal11EventLoggerC2ERKSs in libextern_ceres.a(wall_time.cc.o)
    __ZN5ceres8internal11EventLoggerD2Ev in libextern_ceres.a(wall_time.cc.o)
    __ZN5ceres8internal11EventLogger8AddEventERKSs in libextern_ceres.a(wall_time.cc.o)

ld: symbol(s) not found for architecture x86_64
clang-3.4: error: linker command failed with exit code 1 (use -v to see invocation)
make[2]: * [bin/blenderplayer.app/Contents/MacOS/blenderplayer] Error 1
make[1]:
* [source/blenderplayer/CMakeFiles/blenderplayer.dir/all] Error 2
make[1]: * Waiting for unfinished jobs....
Linking CXX static library ../../../lib/libbf_intern_cycles.a
[100%] Built target bf_intern_cycles
make:
* [all] Error 2

I get crazy
I just forgot to propagate the flags too (therefore the link issue), but when i do, configuring fails again as before.
Dammit, there must be another hidden issue.
Stay tuned , i may do this from scratch...

Jens

Let's stay calm Jens
To tell the truth, my most concern is, why Ton still builds in buildbot without supporting OpenMP? I wonder.
Irrelevant to this thread, but still wondering.

Simply because no one changed the buildbot yet, and Ton is busy. ;)

Michalis

I found the true reason now.
It is due the special clang open-mp env ( with dylib ) the tests fail with -fopennmp.
If i only add then to release flags it works again, but thats an ugly hack.

I think it must be the tests Sergey introduced with the commit you mentioned as "breaker",
so i must find either a way to test these without openmp ( release flags on way, remove temporary another )
or make sure the tests ( which are indeed little testcompiles ) get the openmplib linked somehow.

It makes my brain smoke atm. but will get it soon.

Jens

Pushed an intermediate fix to be able to make at least relese type builds

Jens

That worked.
Thank you Jens
Building successfully with everything ON
configuration, like this

cd /Volumes/HD_3/blender-src/blender;
git checkout master;
git pull --rebase;
git submodule foreach git pull --rebase origin master;
cd ../lib/darwin-9.x.universal;
svn up;
cd ../../blender-build;
rm CMakeCache.txt;
cmake ../blender -DCMAKE_C_COMPILER="/Volumes/HD_3/blender-src/lib/darwin-9.x.universal/clang-omp/bin/clang" -DCMAKE_CXX_COMPILER="/Volumes/HD_3/blender-src/lib/darwin-9.x.universal/clang-omp/bin/clang++" -DWITH_OPENMP=ON -DWITH_CYCLES_OSL=ON -DWITH_CODEC_FFMPEG=ON -DWITH_MOD_OCEANSIM=ON -DWITH_FFTW3=ON -DWITH_RAYOPTIMIZATION=ON -DWITH_LIBMV=ON -DWITH_PLAYER=ON;
make install -j16;

I extended this workaround to all build_types now.
I am aware the clang-omp in darwin libs is an uncommon
install_prefix. But i think compiling on its own and have
this in /usr/local as typical is not convenient and hard todo
for usual users, due complicated compile of clang and expecially
intel openmp ( perl based )

As we have not such problems in scons, i think we can life with this hack for now, until some other
smart brain comes up with a better solution.

Jens

jensverwiebe: The way it's set up now is really nice. I could never get the /usr/local thing to work because of differences in all the instructions across multiple versions of OSX, the compilers, dependency packages, setting up sym-links, environment paths and whatever else there is to do for that. It's a tangled and convoluted mess.

People who share my limited abilities in this area could always fall back on using xCode but having everything that is necessary and all ready to go in the blender libs folder is unusually pleasant and easy to work with.

Well, whatever you think is best here. Cheers.

fix aac283966f66
success
thank you

here we are again
tried to build today

clang-3.4: error: linker command failed with exit code 1 (use -v to see invocation)
make[2]: * [bin/blender.app/Contents/MacOS/blender] Error 1
make[1]:
* [source/creator/CMakeFiles/blender.dir/all] Error 2
make: *** [all] Error 2

I builded successfully two days ago.

OK
I can build successfully with the following configuration
Probably a conflict with cycles OSL?

cd /Volumes/HD_3/blender-src/blender;
git checkout master;
git pull --rebase;
git submodule foreach git pull --rebase origin master;
cd ../lib/darwin-9.x.universal;
svn up;
cd ../../blender-build;
rm CMakeCache.txt;
cmake ../blender -DCMAKE_C_COMPILER="/Volumes/HD_3/blender-src/lib/darwin-9.x.universal/clang-omp/bin/clang" -DCMAKE_CXX_COMPILER="/Volumes/HD_3/blender-src/lib/darwin-9.x.universal/clang-omp/bin/clang++" -DWITH_OPENMP=ON -DWITH_CYCLES_OSL=OFF -DWITH_CODEC_FFMPEG=ON -DWITH_MOD_OCEANSIM=ON -DWITH_FFTW3=ON -DWITH_RAYOPTIMIZATION=ON -DWITH_LIBMV=ON -DWITH_PLAYER=ON;
make install -j16;

Thank you so much!!
Can build with OSL cycles ON
Fixed.

Can't build, once again.

ld: symbol(s) not found for architecture x86_64
clang-3.4: error: linker command failed with exit code 1 (use -v to see invocation)
make[2]: * [bin/blender.app/Contents/MacOS/blender] Error 1
make[1]:
* [source/creator/CMakeFiles/blender.dir/all] Error 2
make: *** [all] Error 2

there is a huge list of undefined symbols

Undefined symbols for architecture x86_64:
….

edit:
forgot to mention
I can build with OSL OFF
here it is
cmake ../blender -DCMAKE_C_COMPILER="/Volumes/HD_3/blender-src/lib/darwin-9.x.universal/clang-omp/bin/clang" -DCMAKE_CXX_COMPILER="/Volumes/HD_3/blender-src/lib/darwin-9.x.universal/clang-omp/bin/clang++" -DWITH_OPENMP=ON -DWITH_CYCLES_OSL=OFF -DWITH_CODEC_FFMPEG=ON -DWITH_MOD_OCEANSIM=ON -DWITH_FFTW3=ON -DWITH_RAYOPTIMIZATION=ON -DWITH_LIBMV=ON -DWITH_PLAYER=ON;

Once again, the bug tracker is not supposed to be used for reports about compilation errors. They might happen 10 times a day, and having comments about each of them would make us simply run out of the space on the database machine.

This stuff better be communicated in the mailing list or IRC. So please stop making this taks totally unreadable and unmanageable with the gadzillions of the compilation errors.

P.S. We're really interested in making blender to work, but we also like to keep tools we're using (such as task tracker) under the control.

Fixed now, thanks you jens and all the other crew