Page MenuHome

"View as render" button in Background image settings, no purpose
Closed, ArchivedPublic

Description

System Information
Windows vista 64bit, Windows 7 64bit

Blender Version
Broken: 2.71 9337574

Short description of error
As shown in the two screen shots, the View as render check box has no effect in the 3D view. View as render works as should in the image editor, but has no effect in the 3D view. So the option should not be in the background image settings.
same question on blender exchange
With View as render off.


With View as render on.

Exact steps for others to reproduce the error

  1. Load a image as a background image in the 3D view.
  2. Change the color management settings, as to see a difference in the image.
  3. Toggle on and of the View as render

Details

Type
Bug

Event Timeline

David (Davd) updated the task description. (Show Details)Jul 9 2014, 4:46 AM
David (Davd) set Type to Bug.
David (Davd) added a subscriber: David (Davd).
David (Davd) created this task.
David (Davd) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) closed this task as Archived.Jul 9 2014, 9:34 AM
Sergey Sharybin (sergey) claimed this task.

There you see an image datablock settings, which could make no sense in some areas (it could be nice to have this option affecting background images as well tho), but makes total sense in other areas (like image editor).

We could try adding an options to image datablock template to hide some particular options, but don't think it actually worth doing it -- code would become much more cluttered.

Thanks for the report, but it's rather some UI thing which could be improved rather than a bug.

This still seems to be not working. It would be extremely useful to get the view as render to work in the viewport background images.
Lighting and matching CG to image plates would get a lot easier if one could actually see the image plates in the right color space in the viewport.

Right now when matching lighting and colours to a plate(linear EXR, ACES_cg or such) one has to either bake the luts to an image used as the background image or add an emissive image plane in cycles with only camera rays enabled to get the wanted result. Both requiring extra setup time.


same applies to both 2.79 and 2.80