Page MenuHome

AV-sync lags with default cube
Closed, ArchivedPublic

Description

System Information
Operating System: Windows 8.1, 64-bit
Graphics Card: ASUS GeForce GTX 780 DirectCU II OC 3GB GDDR5
Processor: Intel Core i7-3770 @ 3.40 GHz
Memory: 12.0 GB DDR3

Blender Version
Broken: 2.71
Worked: 2.70a

Short description of error
Using AV-sync with default cube in 2.71 indicates a consistent 24 fps, but actually plays at ~4 fps.

Exact steps for others to reproduce the error
Open 2.71 startup file, turn on AV-sync and playback animation.

Details

Type
Bug

Event Timeline

Sergey Sharybin (sergey) triaged this task as Normal priority.Jul 10 2014, 6:55 PM

Neither @Thomas Dinges (dingto) nor I could reproduce the bug. Does it depend on the audio system you are using? Try changing from OpenAL to SDL in User Preferences -> System and see if that changes anything.

Also how can you see those ~4 fps? Is the timeline moving that slow? Because the file you attached or the default startup file has no animation.

Switching from SDL audio to OpenAL fixed the problem with both the timeline and the 3D viewport. But what could cause this problem with SDL's audio sync?

And yeah, in the file I attached the frame number indicator on the timeline was the one that moved at around 4 fps. However in a different file with animation, the 3D viewport was also moving slower than the fps indicator.

Interesting, why did you configure SDL as audio system? Normally OpenAL should be default. I tried again now with SDL, but still cannot reproduce the bug. I wonder if it's just a windows 8 thing? Do you have a chance to test it on a windows 7 computer?

Unfortunately, I don't have access to a computer running Windows 7. I ran Blender on compatibility mode's Windows 7 but the SDL audio device still caused AV-sync to lag. I don't remember exactly why or when my default was set to SDL because I've been using a custom startup file for nearly a year, but I'm guessing it's because I was trying to see how it differs from OpenAL and forgot, or didn't get the chance to switch it back before saving a new startup file.

Some additional information- manually scrolling through the timeline with the mouse, on SDL's audio device and with AV-sync enabled and even with audio scrubbing turned on, doesn't lag the animation. It only lags when I try to playback the animation in an editor window.

When using SDL, which buffer size did you setup in the settings? Maybe that's too high?

The buffer size for SDL is set to 2048. Setting it to 256 added a slight ~1.0 frame per second and switching it to 32768 basically cut the entire frame rate in half. Various combinations of all the other audio settings didn't seem to make any difference, and none of the audio settings changed on OpenAL made it run slower.

I just tried this bug on the PC of a friend with the official 2.71 zip file and I can reproduce the problems with windows 8. The problem however is in the SDL library and cannot be fixed from here. The only thing we can try is if updating the SDL libraries helps. @Sergey Sharybin (sergey) @Martijn Berger (juicyfruit) maybe one of you can look into this?

Sergey Sharybin (sergey) closed this task as Archived.Dec 26 2014, 10:12 AM

We've upgraded now to latest SDL-2.0 now. If the issue is with SDL, you'd better report issue to their tracker i believe. We can not solve bugs in code we don't maintain.

So thanks for the report, but we did everything we could here..