Page MenuHome

Face snapping doesn't work properly
Closed, ResolvedPublic

Description

System Information
Ubuntu 14.04
GXT 680

Blender Version
Broken: 2.71 51120ef
Worked: 2.71 official

Short description of error
Face snapping doesn't work properly. If I have two parts of mesh, and I want to snap one to the other by using face snapping it doesn't work. If I separate one part in new object, then face snapping works correctly.

Exact steps for others to reproduce the error
Open default scene. Delete Cube and add UV Sphere for example. Select Sphere and enter editmode. In edit mode add Plane, subdivide it couple times, enable face snapping, enable snapping to it self, activate grad/move action, press Ctrl to snap ... and it doesn't work. If I select the Plane, separate in new object, then in edit mode of that Plane everithing behaves how it should.

Event Timeline

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.EditedJul 27 2014, 9:42 AM

Works for me on latest master… Please attach a .blend file (always simple to reproduce the issue, even when steps are simple and clear).

Also, you say:

enable face snapping, enable snapping to it self, activate grad/move action, press Ctrl to snap

Which won't work, either you do not enable snapping and use ctrl to activate it, or you do enable snapping, and then ctrl will disable it…

Hi,
I'm sorry if my description is not clear ... english isn't my native language.

Enyway I attach scene where in Blender version mentioned in description, when I activate grab + Ctrl, then nothing happens, but in official release everithing works just fine.

Sergey Sharybin (sergey) raised the priority of this task from Needs Information from User to Normal.Jul 28 2014, 2:06 PM

Can indeed see the difference in behavior.

@Bastien Montagne (mont29), mind having a check here? :)

Yep, can confirm the issue, in Ortho view only though, this projection is really a pita for snapping :/