Page MenuHome

Loop cut: Adding more than one cut defaults to Edge Select; even if in Vertex Select.
Closed, ResolvedPublic

Description

System Information
Windows 7 (GTX 780 Ti + GTX 580 Classified)
Max OS X 10.7.5 (AMD Radeon HD 6770M)

Blender Version
Broken: 2.71 (9337574)
Worked: Any version under 2.7

Short description of error
Whenever I add loop cuts (Control + R), and use the mouse-wheel to scroll up and add more than one cut, after applying the cuts, Blender always defaults to "Edge Select", even though I'm in "Vertex Select". I have to manually re-select "Vertex Select" to continue editing as I was previous to the loop cut, every single time.

Exact steps for others to reproduce the error
I attached an image showing this issue, it'll work on any new file with the default cube.

  1. Highlighted in red is the selection mode I'm in, you'll see it's in "Vertex Select".
  1. If I just add 1 single loop cut, Blender will resume the selected mode I'm in (Vertex).
  1. If I add more than 1 loop cut with the mouse wheel and apply it, you will see that it switches to "Edge Select". It shouldn't do that, it should go back to the previously selected "Vertex Select".

I don't know if this is a bug or feature, but it's extremely annoying having to switch back to "Vertex Select" every single time I make more than one loop cut.

Details

Type
Bug

Event Timeline

Dee Grimm (total_legend) set Type to Bug.
Dee Grimm (total_legend) created this task.
Dee Grimm (total_legend) raised the priority of this task from to Needs Triage by Developer.

Can confirm the issue on Linux 64 with latest head.

This is working as intended, without this - edge-slide would fail.

Also, switching back to vertex mode would select all faces in between the edges.

I believe you're misunderstanding the problem.

Being in Edge Select for sliding is perfectly fine during the actual loop cut process; but when the loop cut is finished and applied, we no longer need to use edge slide. Like in previous versions of Blender, it should revert back to he original selection type before entering loop cut.

This isn't about what Selection type Blender enters as we're making the cuts (Edge), it's about what happens AFTER the cuts are applied in that it remains in Edge Select every single time.

Bastien Montagne (mont29) closed this task as Invalid.

We have already replied to this: no, it is not possible to go back to vertex selection, by design and because it would jeopardize the fact that only new elements are selected once the operator is finished.

So before reopening tasks (which you should never do, this is not a user's decision to make), I suggest you read the answer next time.

And again (too), a bug is when code does not work as intended, not when users think it should work otherwise - that is feature request or design task, and has nothing to do on the tracker.

I've read the answer, and it doesn't address the actual issue, and neither does yours Monty.

This wasn't a problem in all recent versions prior to 2.7, but something has changed (for the worse) since then. This design feature behaves more like a bug than an actual feature. So why intentionally cripple a feature that worked perfectly fine for years?

In the 2.6 series — even as recent as 2.69 — we actually had choices on the results of the finished and applied Loop Cut operation:

  • If you enter the Loop Cut operation and make several cuts while in Vertex Select mode, the operation ends with the newly created Faces selected, as intended.
  • If you enter the Loop Cut operation and make several cuts while in Edge Select mode, the results end with the newly created Edges selected as intended; just like the new default in 2.7.

The difference is that 2.7 does not return back to its original selection mode as it does in 2.6, and instead forces the selection to Edge Select mode.

This isn't about what I think how it should work, because this is how it actually worked before this version of Blender. You should consider actually replicating this problem on your end, and compare it between 2.6 and 2.7 to see for yourself.

You don't want us to re-open tasks, but the option exists for us to do so. Is that a bug, or a design feature, too?

If you think this is an issue, you can start a thread on BA, or on our ML…

If you're implying that I'm just some random BA Forum user who's griping about something insignificant, then you have it all wrong. I still invite you to run this issue through 2.69 and compare it with 2.71, so that you too can see that this is in fact — and undeniably — broken; and is something worth fixing considering it's a very significant part of modeling.

Could you (or someone else) please take a moment to actually look into this from the perspective of an end-user and not so much a developer? We had something that worked flawlessly, and then you took it away by design (if not a bug). This 2.7 "design" feature with Loop Cuts is very counter-productive to us non-developers who actually use Blender in daily real-world scenarios.

There shouldn't have to be a petition started on a forum or a Mailing list to fix or restore a useful feature that had always been a part of Blender.

@Dee Grimm (total_legend) - the purpose of the bug tracker is to handle software errors or incorrect behavior, currently this works as intended.

Of course there are many areas we can improve on, or redesign behavior, but thats another issue.

Campbell, I want you to look at this report that you replied to, which not only did you acknowledge existed, but was also marked as resolved and actually fixed. The issue I am bringing up here is the exact same issue in that report.

https://developer.blender.org/T35302

You have to understand: I don't want to be in Vertex Select mode WHILE sliding edges during a Loop Cut (I understand this needs to be in Edge Select mode during this process); I just want to revert BACK to the original mode (Vertex Select Mode) after the sliding and the cutting has been applied to a mesh, so I don't have to click on the Vertex Select button after every single loop cut operation I perform. It slows down work flow significantly, in fact it's to the point where I won't even use the scroll feature to add more cuts due to its bug-like annoyance.

If I'm in a specific mode of selection before doing this cut (Vertex) that's because I intended for the results to be faces and not edges after the cuts are applied, as it was beautifully executed in pre-2.7. If this truly isn't a bug, then why did you remove this feature, or assume that just because we're doing loops cuts that we want Edges to be selected in the post process?

Again, this intentional design works more like a bug than an actual feature.

Otherwise: If you're going to continue to push the whole "it works as intended" reply, then who (person or group) do I have to make a "feature" request with to bring back a working function that was decimated in 2.7?

Campbell Barton (campbellbarton) changed the task status from Invalid to Resolved.EditedAug 14 2014, 4:10 AM

Checking and this did indeed used to work, corrected rB15df4ddf7b1578ae1ef80fdce428570d66b1b69a

I should have remembered since I added USE_LOOPSLIDE_HACK to begin with, My bad!, sorry for the confusion.

Thank you for acknowledging and looking into this issue.

I'll get off your back now. :)

@Sergei Smyslov (Luarvik) - this initial mistake has been corrected, the tracker is not a forum to vent opinions.