Page MenuHome

Drastic performance loss using motion deformation blur with activated explode modifier
Open, Confirmed, LowPublic

Description

System Information
Debian GNU/Linux Jessie (testing)
AMD Phenom II X4 850

Blender Version
Broken: since added motion deformation blur
Worked: before and now with normal motion blur

Short description of error
Once particle system and explode modifier(!) got applied, render performance becomes unusable. See also [1].

Exact steps for others to reproduce the error

  • enable motion blur with deformation
  • remesh standard cube
  • add particle system
  • add blend texture
  • and the most important: apply explode modifier (leave only Unborn enabled)

Test file attached:

The frame 1 where the particle system is not yet active is rendered promptly. Go to the frame 2 and the render process becomes extremely slow, though the region being rendered doesn't get changed by the particle system, because of the blend texture: only the almost left side emits particle at start.

Thanks,
Andrey

(1) https://developer.blender.org/T41512

Details

Type
To Do

Event Timeline

Andrey (ag) raised the priority of this task from to Needs Triage by Developer.
Andrey (ag) updated the task description. (Show Details)
Andrey (ag) set Type to Bug.
Andrey (ag) added a subscriber: Andrey (ag).

Yep confirmed , make you look at the screen and say "hello render!"

GTX 650 4gb driver 340.52 Win 8.1 64 bit

Thomas Dinges (dingto) lowered the priority of this task from Needs Triage by Developer to Confirmed, Low.Aug 26 2014, 3:40 AM

I thought you meant the "Freestyle" issue when asking to open a new report, not to report the same motion blur issue a second time. :)

Anyway, Deformation Motion Blur can be disabled, it is optional and also it hasn't been optimized yet at all. I will investigate this more, but setting the priority to Low now, as I think this is rather unoptimized code than a bug.

Julian Eisel (Severin) closed this task as Invalid.Feb 23 2015, 11:50 PM

This clearly sounds like a Todo!

Julian Eisel (Severin) changed Type from Bug to To Do.Feb 23 2015, 11:50 PM