Page MenuHome

issue with moving nodes and in UI with custom setup
Closed, ArchivedPublic

Description

System Information
win 7 x64

Blender Version
Broken: 2.72
Worked: 2.6x- 2.71

Short description of error
In normal case you can move nodes by LMB, RMB or by press B. In this blend file in my configuration setup, moving nodes is accidential.
Some time it moves by LMB other time RMB and another time at all. In default settings it works fine. Also in panel user preferences tooltips don't work if you are above some function.
Exact steps for others to reproduce the error
open blend file and try to move some of two nodes every time using LMB or RMB.

Details

Type
Bug

Event Timeline

daniel (midan) claimed this task.
daniel (midan) raised the priority of this task from to Needs Triage by Developer.
daniel (midan) updated the task description. (Show Details)
daniel (midan) added a project: BF Blender.
daniel (midan) set Type to Bug.
daniel (midan) added a subscriber: daniel (midan).

We won’t support custom settings, unless you can prove us there is a real bug with it - not incidental breaking due to random custom settings… So unless you give us a very few changes to do to default settings to reproduce your issue, we can’t do anything. Golden rule of bug report: case must be easily reproducible.

Bastien Montagne (mont29) removed daniel (midan) as the assignee of this task.Oct 6 2014, 7:37 PM
Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.

but there is nothing special in my settings, just different colours of UI, some shortcuts and arrangement of panels.In one word - only the look There was no problem in blender 2.71 build 1477- the latest I have that works. I have no idea what causes problem, maybe something happened with startup file with 2.72

There is something special in your settings, since it does happen with factory settings!

But investigating which of your changes creates the issue it’s up to you to do…

I have made a research and it is as follows:

  1. in factory settings when I take and drop my startup blend file into 3d view everything works perfect. but when I then save startup file and reopen blender the problem comeback.
  2. after some time of trials I came up with a solution
      • in factory settings I take and drop my userpref blend file into 3dview , load my keyconfig file, and then save user settings.
    • reopen blender and save startup file. And it works as it should be.

so my settings are not a problem. there is something in startup file itself , because it does not work neither "copy previous settings" in splash screen nor dropping startup file into 3dview window and then saving startup file.

Bastien Montagne (mont29) closed this task as Archived.Oct 16 2014, 9:08 AM
Bastien Montagne (mont29) claimed this task.

We can’t do much against data corruption, unless you can give us a very precise way to reproduce it. In such case, it’s usually better to just delete local userpref files and start again from scratch…

Anyway, since you manage to to fix the situation, think we can close the report, thanks.