Numkey "." (dot) not working
Closed, ArchivedPublic

Description

System Information
ASUS M4A78T-E / AMD Athlon II x3 425 2.7GHz / Kingston 8GB DDR3 1333MHz / NVIDIA GeForce GTX 550 Ti (2GB) / Windows XP SP2 x64

Blender Version
Broken:
2.72 2014-10-03 13:58 32-bit
2.71 2014-06-25 18:36 32-bit
2.70a 2014-04-10 11:49 32-bit
2.69 r60995 32-bit
Zip files dowloaded - not exe / installed.

Short description of error
I can't use the "." (dot) key in the numpad (numeric pad) in my desktop PC.
The key doesn't seem to be recognized.
Other keys do work.
Does work with other programs.

Exact steps for others to reproduce the error
Open Blender, select any object and try to "View Selected".
Also, open/create any text file and try to type "." (a dot) with the numpad.

Details

Type
Bug
Ricardo Roehe (phoinx) updated the task description. (Show Details)
Ricardo Roehe (phoinx) raised the priority of this task from to Needs Triage.
Ricardo Roehe (phoinx) set Type to Bug.

Here, with Win7/64, "view selected" works well with NumLock Off as well as On. However, in a text window, it only works if NumLock is on, i.e. it doesn't delete a char with NumLock=Off. Unfortunatelly, the navigation keys (arrow, home, end) on NumPad do not work either.

When you open the settings (Alt+Ctrl+U), on the "Input" tab, if you enter "view selected" in the search textbox, which result do you get? I get this:

(BTW, I hope you're not connected to the Internet with only SP2)

Sergey Sharybin (sergey) triaged this task as Normal priority.Oct 7 2014, 9:30 AM

Are you using QWERTY keyboard layout?

I don't have a keybaord with real numpad by hand now. @Thomas Dinges (dingto), @Martijn Berger (juicyfruit) can you test this?

@Armin Zingler (willi)
User settings are the same as yours.
It doesn't matter to me if the NumLock is ON or OFF - keys always work.
However, with text block, there is this behavior with NumLock OFF:

  • numbers, "," and "." DON'T work;
  • /*-+ and Enter DO work.

(P.S.: there is no SP3 for 64-bit Windows XP. =[ )

@Sergey Sharybin (sergey)
Yes, QWERTY.

Curious: the numkey "," (comma) and the combination "Ctrl + ," seems to activate "View Selected". The input of that key (comma) is ok (with texts and as shortcut).

Also, problem does not occur with Linux (Mint 13 x64).

Also, I could not open Blender 64-bit on Windows - I receive a "not a valid Win32 application" message (in console I can only see "Access is denied." after the prompt message is closed).

Windows XP x64 is not supported by the 64 bit builds of blender. They require a full patched vista or newer. and we recommend windows 7 SP1 or newer there

@Martijn Berger (juicyfruit)
Ok. Thank you.

But, how about the Numpad behavior? Is that related with running a 32-bit version of Blender on a 64-bit system?

Just realized: the "/?°" key (simple press, shift+key and AltGr+key, repectively) - outside from Numpad - is not working as well (no output in a text block).

Sergey Sharybin (sergey) closed this task as Archived.Oct 14 2014, 10:53 AM
Sergey Sharybin (sergey) claimed this task.

I can not reproduce the issue with neither 64bit nor 32bit blender on win7 64bit. The thing is -- winxp 64bit is not officially supported, it might have some serious issues with drivers and so. unless you'll manage to reproduce the issue with newer windows or 32bit xp wouldn't consider this is a bug.

Thanks for the report, but for until someone manages to reproduce the issue on a supported platform will keep this one archived.

Ok. Fair enough.

Weird thing is I have used Blender with WinXP64 before, without problems. But now I can't make a single version work here (regarding the dot key). Might be a driver issue indeed.

Thank you, fellas!

Ricardo Roehe (phoinx) reopened this task as Open.Jul 19 2017, 4:09 PM

Greetings!

Started using Windows 10 Home 64-bit recently and can confirm the exact problems reported here: numpad dot/period and key for "/?°" (Portuguese Brazil ABNT2 keyboard) gives no input inside Blender.

Sergey Sharybin (sergey) raised the priority of this task from Normal to Needs Triage.

What version of Blender?

2.78c (.msi), 2.79rc2, 2.80.1 3ab46f4

@Ricardo Roehe (phoinx) I suspect your Brazilian keyboard is sending a comma instead of a period.

In the Logic Editor add a Keyboard sensor, mouse click in the "Key" and press your Numpad dot. What does it show?

Also, if you replace the "View Selected" shortcut in your user preferences to you your NUMPAD dot, does it show what? And does the new shortcut work?

Hi, @Dalai Felinto (dfelinto) !

The keyboard sensor detects the Numpad "," (comma) as "Numpad ." (dot/period).

It does not detect the Numpad "." (dot/period) at all (nothing happens, Blender keeps waiting for input with the "Press a key" message).

Since the key is not being detected, I cannot change the "View Selected" shortcut either (nothing happens, Blender keeps waiting for input with the "Press a key" message).

Just for safety, I tried a new keyaboard (hardware), and still get the same behavior.

Can you go here http://www.keyboardtester.com/
and hit the "." key on your Numpad and report what it shows?

LazyDodo (LazyDodo) triaged this task as Incomplete priority.Sep 28 2017, 7:25 PM
  1. Is this still an issue?
  1. For me to repro this, i'll probably have to match your keyboard settings in windows can you take a screenshot of this window on your windows installation?

Bastien Montagne (mont29) claimed this task.

More than a week without reply. Due to the policy of the tracker archiving for until required info/data are provided.