Page MenuHome

Baking AO in BI fails with wire material
Closed, ArchivedPublic

Description

System Information
Archlinux
GTX 460

Blender Version
Broken: beaed66, 2.72b

Short description of error
Baking AO gives a lot of z fighting and strange artifacts when a wire material is present.
See http://blender.stackexchange.com/q/18156/599

Exact steps for others to reproduce the error

  1. Open and press bake. Bake has a lot of artifacts.
  2. Delete the wire material and try again. Bakes normally.

Details

Type
Bug

Event Timeline

Ellwood Zwovic (gandalf3) set Type to Bug.
Ellwood Zwovic (gandalf3) created this task.
Ellwood Zwovic (gandalf3) raised the priority of this task from to Needs Triage by Developer.

Confirmed this on OS X 10.8.5.
Though I'm wondering if this is really a bug or expected behavior. If you put the normal material on top and the wire material below (I know, this doesn't make any sense) the problem is gone. So it seems like the wire material is 'in the way' of the occlusion rendering so to speak.

That's probably what is happening, which would explain why it looks like Z-fighting.
I would have expected the wire material to be ignored completely though, since only AO was being baked (which AFAIK usually ignores materials).

That said, it's a pretty minor bug in that it has an easy workaround..

"...which AFAIK ususally ignores materials..." reminded me of something. Actually it doesn't ignore materials, so it can take the bump/displacement map into account for example. If you do not want this, there is an option you can tick: Normalized Just tried it and this fixes your problem.

Bastien Montagne (mont29) claimed this task.

Eeeeh, then, think we can archive this one, right? Thanks for the report, anyway.