Page MenuHome

Knife cut fails at different scales (float precision)
Closed, ResolvedPublic

Description

System Information
Operating system and graphics card
win 7 nvidia 550 ti
Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen) blender 2.72 625843d
Worked: (optional) I don't know

Short description of error
While using the knife cut i may be pressed some buttons by mistake and now the knife cut tools have a lot of red dot that follow my direction and when i cut anyway, i got triangles all over the place. Did i corrupt this file?

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps


In the .blend file hit k and LMB click and there you go ...


@Campbell Barton (campbellbarton) (noting)
attaching another file from T42864 . Its related to scale (use knife project)

Event Timeline

It looks like we could support this however - the object is ~0.005 dimensions, causing precision issues.

Thanks after reading this i scaled it and problem solved, I started this mode without ref. image and with just a vertex that why the scale was off.

Bastien Montagne (mont29) removed Bastien Montagne (mont29) as the assignee of this task.

@Erick Tukuniata (erickblender) please only assign bugs yourself if you are really sure you know to whom you should assign…

Campbell, not really sure we can do much about such issues currently… Esp. since it's again in ortho view (persp one seems to work OK here afaict), raycasting in ortho has always been kind of a nightmare. :/

Bastien Montagne (mont29) triaged this task as Normal priority.Nov 1 2014, 2:53 PM

Sorry Mont29,
I was thinking that the modeling section is you and Campbell but eventually i m wrong. Tell me to whom to assign this kind of bug so that next time i can do it right.

@Campbell Barton (campbellbarton), wouldn't really consider it a bug and will move to TODO. Murphy will always ensure you've got just one ore precision issue if you solve all known onces :)

Campbell Barton (campbellbarton) renamed this task from Knife cut strange behavior to Knife cut fails at different scales (float precision).Dec 16 2014, 10:31 AM
Julian Eisel (Severin) closed this task as Resolved.Jan 13 2015, 12:13 PM

Not so fast :)

While it can almost cut correctly, there is a precission problem where the knife cuts all the way through the ants-boots (occlude faces fails).