Page MenuHome

Material flickering in viewport
Closed, ResolvedPublic

Description

System Information
Windows 7 x64 & GeForce GT 740M

Blender Version
2.73

Short description of error
In this new 2.73 version, sometimes I see some kind of flickering of material color in viewport, and I'm not sure, but it has something to do with opening projects started in Blender 2.72b.

Here is a saved project, that if you select one of face in front of you, you will see that other faces are getting darker
http://www19.zippyshare.com/v/uR5I03tV/file.html

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Event Timeline

Łukasz Debita (evilferber) created this task.
Łukasz Debita (evilferber) raised the priority of this task from to Needs Triage by Developer.

I can't confirm this here, but I remember we had a similar issue which was caused by the graphics drivers. So let's try two things at first:

  • make sure you're using latest graphics drivers
  • use this dll and place it in the folder next to the blender.exe (will be slow but shows us if it's a driver issue)
Julian Eisel (Severin) triaged this task as Needs Information from User priority.Jan 11 2015, 4:03 PM

I have the newest drivers, everything is working fine, blender 2.62b was working beautiful.

I placed opengl dll as you wished, and yeah, it is slow ;D And the issue is gone, no problem with viewport. What is that mean ?

Can't reproduce the issue here (Geforce 540)

Saving the file in blender 2.72 and opening in 2.73 does not have the problem.

A few tests would help:

  • Can you try with factory settings?
  • Does the VBO option in the user preferences influence this
  • I assume you have the latest driver installed for your graphics card? In any case can you paste your system_info.txt from blender?
Julian Eisel (Severin) closed this task as Invalid.EditedJan 11 2015, 4:21 PM
Julian Eisel (Severin) claimed this task.

@Łukasz Debita (evilferber) This means we have no bug here ;)

This definitely is a driver issue, so we can't do much from our side. You could try if downgrading the driver helps or wait for NVidia to release a new one which fixes the issue.

First of all, I discovered that when I'm running blender with my integrated graphics card I don't have that issue.
Factory settings didn't help.
VBO doesn't influance this.
Where is that system_info.txt in blender?
Just after publishing this post, I will install the newest driver for my video card (reinstal rather), maybe this will help.

http://pastebin.com/mkApJk6f -That's my system_info.txt.

After ALL upgrades, reinstalling the newest drivers the problem is still there, and BLENDER 2.72B DOES NOT have this issue...
When I'm running the same project in 2.72b using GeForce GT 740M there is NO PROBLEM, when I run it with 2.73 the problem is.

Any ideas?

Well, two out of three opengl implementations don't have the issue, so you'll have to wait for an upgraded driver from NVIDIA I guess. The weird thing is that I have the exact same driver here - of course implementations can be different for different OSs/GPUs.

One last thing - though I find it unlikely that it will help us reproduce - is that we don't have the exact same file here as the one in the video. We need an exact setup right before the issue. Of course if the file you posted is supposed to have the issue if one just changes the selection then there's really nothing we can do here.

dear Antony Riakiotakis, please, see by yourself
https://www.youtube.com/watch?v=2h0Gm88A7QQ&feature=youtu.be

After reinstalling drivers and updating GeForce Experience (some kind of small installations were done) it's a bit better as You see, but still that material flickering is annoying, besides here I have grey wall so it's not so bad after changing into darker grey, but it happend to me before when I had colorish material, and the flickering was making the material grey, so it was battle between grey and blue or something like that, very annoying.

And... why is 2.72b working good with my "bad drivers"? I just finished the project in 2.72b without any problems. Maybe there were some diffrences in viewport rendering in blender?
Please answer... ; (((

Confirmed, see, it's always important to attach the exact same file ;)

Antony Riakiotakis (psy-fi) raised the priority of this task from Needs Information from User to Normal.

Thank You!!! Blender 2.73a run that file without any errors ; ))) So now I can really switch to 2.73 ;D