Page MenuHome

(global) Undo on an armature kicks me out of Pose mode
Closed, ResolvedPublic

Description

System Information
manjaro linux latest, ati mobility radeon 4560

Blender Version
Broken: blender-2.73-1b1a6e0-linux-glibc211-x86_64
Worked: 2.72b

Short description of error
Undo doesnt work at all if not set to "Global" in the preferences.
When in Pose mode (armature), clicking ctrl+z to UNDO kicks the user out of pose mode and back in object mode.
This is extremely annoying as one has to go back to pose mode every time the undo command is issued in pose mode.

Exact steps for others to reproduce the error

  1. Create an armature
  2. select it and Go in pose mode
  3. Rotate one of the bones and then hit Ctrl+Z

you will be kicked out of pose mode every time you UNDO

Details

Type
Bug

Event Timeline

Todor Imreorov (blurymind) created this task.
Todor Imreorov (blurymind) raised the priority of this task from to Needs Triage by Developer.
Bastien Montagne (mont29) claimed this task.

You found the solution yourself, enable 'Global' undo in userprefs is more than recommended…

that doesnt resolve the issue at all though :)
It still kicks me out of pose mode when i undo.

It didnt do that in 2.72b

did you actually try to reproduce the bug (with Global undo switched on) before closing it? :D

Eeeeeeh! You mean, you do have 'gloabl undo' enabled? sorry, org report was not so clear here…

In this case, can you please check you have a reasonable number of undo steps and/or have no mem limit?

Otherwise, please attach here the .blend file.

PS: I can assure you this does not happens for me, out of quick test. ;)

Bastien Montagne (mont29) triaged this task as Needs Information from User priority.Jan 22 2015, 5:50 PM

Yeah, I have the defaults atm.Global undo is ticked and Steps is set to 32, memory limit = 0.

I have no idea why it does it. I tried with a fresh settings file- its still switching to object mode when I undo. Is it possible that the bug is specific to linux?

Its just a normal rigify armature (btw I have rigify enabled).
It didnt have this problem in 2.72b

Do not understand… entered pose mode, did a few edits, undo, of course we get out of pose mode in in the end, but not before having undone all edits first… So cannot confirm your issue (and Igm under linux too).

I am also getting the bug in windows. No idea what makes my computer special. I can make a video recording if you like to prove the behavior. :)

Is there a way to debug blender somehow and see why its doing that in the new version?

It seems to be an ellusive bug

Sounds quite weird to me :/ Did you try using factory settings? And are you sure you're using an "official" build? I mean, not a Gooseberry build or such?

Bastien Montagne (mont29) removed Bastien Montagne (mont29) as the assignee of this task.
Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.

Switched to unconfirmed, we need a dev to be able to reproduce the issue, otherwise we cannot investigate it…

Hi,
Loading factory settings and using the 2.73a build seems to have fixed the issue. Mark as solved.

Julian Eisel (Severin) closed this task as Resolved.Jan 30 2015, 1:06 PM
Julian Eisel (Severin) claimed this task.

Ah, nice to hear :)