Page MenuHome

Particle emitted from vertices ignore UV particle texture
Closed, ArchivedPublic

Description

System Information
Windows 7 64-bit, nvidia gtx570

Blender Version
Broken: 2.63a, b636599 (latest 64-bit build from builder.blender.org)
Worked: unknown.

Short description of error

When particles are set to be emitted from vertices they ignore particle textures using uv mapping. Changing emision to 'faces' fixes this on replaying the particles.

Exact steps for others to reproduce the error

Using this file:

  1. Play the particles in the timeline and note they incorrectly emit from right to left (using view that file opens with. Particles take a few 'tries' to emit correctly).
  2. Change particle emission from 'Verts' to 'Faces'.
  3. Replay particles (may take several tries to see refresh) and note they emit from the bottom upwards, which is correct, as determined by the uv mapped blend texture.

Details

Type
Bug

Event Timeline

Ray Mairlot (madog) set Type to Bug.
Ray Mairlot (madog) created this task.
Ray Mairlot (madog) raised the priority of this task from to Needs Triage by Developer.

IMHO, it never worked.
I think that is a known limitation that UVmapped textures only have impact for emission from faces.
Dynamic paint also is not able to control particles emission. It is just faking it by controling particles life.

To achieve this effect, for an emission from verts, we can use Sort Mesh Elements operator in edit mode to modify indexes or order of vertices. Then, just disabling Random checkbox should be enough.

It is easier than using textures.

Sergey Sharybin (sergey) closed this task as Archived.Jan 27 2015, 11:10 AM
Sergey Sharybin (sergey) claimed this task.

It is a known limitation of particles emitted from vertices. The reason for that is that vertex does not have UV, face does. And this is because you can have UV map discontinuities in vertices and it'll be totally unclear which UV to use for the particle.

Thanks for the report, but it's just how blender works currently.