Page MenuHome

Taken proxy
Closed, ResolvedPublic

Description

System Information
Windows 8.1 x64
Renderer: GeForce GTX 860M/PCIe/SSE2

Blender Version
Broken: 2.73.9 9f6f151

Short description of error
Proxy options where taken.

I don't know who you are. I don't know what you want. If you are looking for ransom, I can tell you I don't have money.
But what I do have are a very particular set of skills…

Exact steps for others to reproduce the error

  1. Open blend file in 2.73a release: (proxy options are there)
  2. Open blend file in recent master build (only 25% proxy option is available)

Details

Type
Design

Event Timeline

Mikhail Rachinskiy (alm) raised the priority of this task from to Needs Triage by Developer.
Mikhail Rachinskiy (alm) updated the task description. (Show Details)
Mikhail Rachinskiy (alm) set Type to Bug.
Julian Eisel (Severin) lowered the priority of this task from Needs Triage by Developer to Normal.

And there, down below is a nice button with "Set Selected strip proxies" to enable the ones you want

@Antony Riakiotakis (psy-fi), Let me turn this a bit into a design discussion ;)
I think we could improve the way information is displayed here a bit. I went ahead and did some reorganization and came up with something like this:

Further, I don't really like the way the settings are hidden behind the "Set Selected Strip Proxies" button. For me, this button doesn't say anything about what it does, so maybe the old design was a bit better here. I guess the reason you've changed it was to fire up the operator that creates a new proxy? If so, my proposal would be: Bring back the checkboxes (or something similar), and add a button saying something like "Build/Rebuild Proxies". We could communicate visually that the settings and the operator button go together, e.g. by using a layout-box.

Initially we had both, then we agreed that having two ways to set the proxies was confusing too. The advantage of having an operator is that it allows us to set proxy settings for all selected strips, something which would otherwise require a script. I don't mind reorganizing the panel as you show (though I'd like to keep the organization and labels ("Enabled Proxies", Overwrite under the proxies). Probably the information can go just below the buttons to keep all proxy settings together.

Oki, need a fresh mind for this which I don't have atm ;P Will reopen as design task and assign to me so I won't forget it

Julian Eisel (Severin) reopened this task as Open.Mar 2 2015, 6:50 PM
Julian Eisel (Severin) claimed this task.
Julian Eisel (Severin) changed Type from Bug to Design.

So now we could set proxies for selected strips? Awesome! But could you please change the name of this operator to something like: "Proxy Sizes" — simple and comprehensive, and there could be more extensive information in the tooltip.

I really like what Julian did with his mockup, I wish those two operators would fit in a row:

This has been updated since original report. The solution now would be to remove the Set Selected Strip Proxies button would this be an acceptable fix @Julian Eisel (Severin)

Any news here? here is the current UI

Richard Antalik (ISS) closed this task as Resolved.Feb 19 2019, 9:42 PM

Outdated -> closing

I'm sorry for digging this one up, but imo is the proxy panel still a mess.

Ok, but don't dig this one up pls :)

You can create todo task with how the panel could look like. Or post a patch.

If you don't intend to work on the implementation of this yourself, please do not create a todo/design task. These should only be created by people who intend to actually get the task done.

A suggested clean up of the proxy panel is here: https://developer.blender.org/D6077