Page MenuHome

Crash with edge collapse
Closed, InvalidPublic

Description

System Information
Windows 7 64 bit with 64 bit Blender
Nvidia GTX 750 Ti

Blender Version
Broken: (example: 2.73 b4d8fb5)

Short description of error
Blender crashes sometimes when using the edge collapse operator and using undo after it. It also looks like the vertices were displaced randomly just before the crash.
In the uploaded file, I've got a simple subdivided plane with a solidify and a subsurf modifier on it. (Because that's what I used in my project where it happened)

Exact steps for others to reproduce the error
Open this file:

(Already in edit mode)
Press X.
Click on "Edge Collapse".
Press Ctrl + Z
CRASH!

Details

Type
Bug

Event Timeline

Philip Holzmann (Foaly) raised the priority of this task from to Needs Triage by Developer.
Philip Holzmann (Foaly) updated the task description. (Show Details)
Philip Holzmann (Foaly) set Type to Bug.
Julian Eisel (Severin) lowered the priority of this task from Needs Triage by Developer to Needs Information from User.Mar 16 2015, 7:34 PM

Can't recreate that here. Could you test again using a build from buildbot?

Both, the buildbot build and 2.74rc1 don't crash.
Sorry, I should have checked that before reporting the bug.

Julian Eisel (Severin) closed this task as Invalid.Mar 17 2015, 2:13 PM
Julian Eisel (Severin) claimed this task.

Okay, then it seems as it was fixed already. No problem, glad I could help :)