Bad convert of hotkey to 2.74
Closed, ArchivedPublic

Description

System Information
W8.1 64b

Blender Version
2.74 RC2

Short description of error
I am using mu custom hotkeys in blender, some commands have added some only changed. It looks that Blender is revert my changed hotkeys to default, when I use Copy old preferences from splash screen.

Details

Type
Bug
Cenek Strichel (cenda) updated the task description. (Show Details)
Cenek Strichel (cenda) raised the priority of this task from to Needs Triage.
Cenek Strichel (cenda) set Type to Bug.
Bastien Montagne (mont29) triaged this task as Incomplete priority.Mar 24 2015, 12:08 PM

I’m not quite sure what the issue is here, this report is for sure incomplete, we'd at the very least need your settings (startup .blend file) from 2.73, and the 'import' result for 2.74.

But please note we simply cannot support gracefully all and any kind of customization during shortcuts conversions, only defaults settings are expected to be 100% handled correctly.

Sorry, here is my settings:

If you watch to Dopesheet you will see what I screenshoted above. I also tried Export and Import my hotkeys as *.py but it also doesnt work.

Bastien Montagne (mont29) raised the priority of this task from Incomplete to Normal.Mar 24 2015, 12:44 PM

OK, can confirm the issue… Not sure what's going on here, again, it’s very hard to get something 100% working with such an heavily edited keymap.

Note however, that restoring (in 2.74) keymap to default, and importing the keymap exported from 2.73 seems to work as expected here.

Not sure why it fails during 2.73->2.74 conversion…

The exported keymap:

@Cenek Strichel (cenda), does importing the 2.74 keymap to the latest buildbot version work fine?

It is not still converted with latest build. Some default hotkey override my own.

Hrmpf, not sure what to do with this... It is certainly not sure this is a bug in 2.74, could also be a bug in 2.73 or a conflict between the keymaps, etc. I did however not hear any more complaints that this doesn't work, and since there is a workaround as @Bastien Montagne (mont29) said, it's questionable if it's even worth the time to investigate this. @Campbell Barton (campbellbarton), do you have an opinion on this?

Julian Eisel (Severin) lowered the priority of this task from Normal to Low.Apr 24 2015, 4:15 PM

I can confirm that this fails, and has for some time. I always used the workaround @Bastien Montagne (mont29) provided.
The attitude of 'this might not even be worth investigating' is a bit odd, I think. It's something that's broken, and something that's one of the first things a user sees after having upgraded.

Sergey Sharybin (sergey) closed this task as Archived.May 26 2015, 11:07 AM
Sergey Sharybin (sergey) claimed this task.

Wouldn't consider this a bug. this particular case might be supported for conversion, but hotkey code have quite a few cases when it'll fail miserably.We had reasonable amount of such reports, better to handle them all at once.

Made sure the report is listed in our TODO list: http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/UserInterface#Keymap_Editing

Thanks for the report, but archiving it as a TODO.now.