Page MenuHome

Dual GPU not usable in 3D Viewport preview and processive finale rendering
Closed, ArchivedPublic

Description

System Information
MacPro OS X 10.10.2
2 x MSI GTX 970

Blender Version
2.74

Short description of error
Selected dual GTX 970 CUDA rendering only works when doing a normal finale rendering, each GPU working on a tile.
In finale rendering progressive and in 3D viewport rendering there is no speed gain at all.
Actually the 3D viewport rendering is then a tick slower.

As far as I know you should be able to render with two GPUs even in 3D viewport preview.

Details

Type
Bug

Event Timeline

claas eicke (cekuhnendev) set Type to Bug.
claas eicke (cekuhnendev) created this task.
claas eicke (cekuhnendev) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) triaged this task as Needs Information from User priority.

Non-progressive final render does dynamic scheduling of tiles to compute devices, but progressive and viewport rendering slices image horizontally into equal parts and each device does tile work inside those slices. This is needed to guarantee tile is getting rendered by the same exact device for each sample. So if your scene is not equally complex on all slices using multiple GPUs indeed will not show much benefits.

But i'm not sure it's indeed the case for you because there's no files attached which shows the issue (which is actually requested in the bug report submission ;)

So not saying there's no bugs here, but you might just be hitting a known TODO and for further investigation we need to have demo file.

Let me supply you with a demo file. I asumed that with a scene that renders slow on a GTX 970 with two at least in preview mode it would render somewhat faster.

Any news on the demo file this report will be closed tomorrow unless we get a file we could test this with

Ok so I did some more testing. I get very odd results.

3D view port is slower with 2 GPUs sometimes, sometimes a tick faster.
I attached a blend file here{F161675}

And the same I also noticed sometimes happening with the progressive render mode for finale image.

Tile rendering most time with 2 gpus is faster.

Aaron Carlisle (Blendify) raised the priority of this task from Needs Information from User to Normal.Apr 13 2015, 11:04 PM

@claas eicke (cekuhnendev), one more question: do you have SLI enabled?

no - no sli. I was under the assumption that it does not work with SLI.

SLI has negative impact on Cycles performance, that's why was asking. But also so far the slowdown can not be reproduced.

Asked some developers and users in the #blendercoders IRC room and we can not confirm the issue so far, which means it's not really possible to solve it. Moving to unconfirmed projects hoping someone in there will be more lucky.


The issue reported can't be reproduced so far, and has been moved to the BF Blender: Unconfirmed project.
If 2 other people aren't able to redo the bug after 2 weeks, it will be closed.

We appreciate the effort that goes into making bug reports, but to be able to fix bugs we have to be able to redo them.
If there is anything you can provide to help others to reproduce the problem, be sure to include it.

Tested on a GTX590 machine, as well as 2 x gtx580, win7 x64.... both GPUs were active whilst rendering (used GPU-Z to confirm)

Aaron Carlisle (Blendify) closed this task as Archived.Sep 2 2015, 6:20 PM
Aaron Carlisle (Blendify) claimed this task.

Seems like now one was able to reproduce time to archive