Page MenuHome

Unwanted merges of UV vertices, also makes importing FBX in mudbox fail.
Closed, InvalidPublic

Description

Blender Version
Broken: blender-2.74-12661de-win64

Short description of error

When moving identical islands that share vertices on the model to the same place on UV space Blender automatically merges those shared vertices.
This generates problems while editing UV (in other software too) and exports UVs like this to FBX, which makes importing to Mudbox fail (doesn't display correctly, and creates some artifacts on mesh).

Exact steps for others to reproduce the error
Open attached example blend:


You will see two identical islands, move one of them to exact position of the other (you can use incremental snap on X to do this here)

What happens:
Islands merge into one.

What should happen:
Island should share the same UV space but stay disconnected.

What should happen on FBX export:
They also should be separated just sharing the same UV space.

Event Timeline

Przemyslaw Golab (n-pigeon) updated the task description. (Show Details)
Przemyslaw Golab (n-pigeon) raised the priority of this task from to Needs Triage by Developer.
Antony Riakiotakis (psy-fi) claimed this task.

This is currently not possible in blender. There is no notion of "UV islands", rather each face has its own uvs that are handled as shared if they are close together in UV space.

Closing as this is working as intended.

Sorry but intended doesn't mean correct. It makes a lot of troubles, especially when working with FBX that has no notion of UV Seams and rest of the team doesn't use Blender.

Maybe at least some work around so it will export to FBX properly?

Blender itself can't figure out what the UV islands would be in that case, but I'll just add @Bastien Montagne (mont29) here in case he can figure out something. What could work in the whole island detection algorithm is to see if two faces have the same winding in UV space before attaching a face to an island.

Reopening, I think we could even support this kind of island detection in blender too.

Huge thanks. I'm really grateful for any even attempt of fixing this. :)

Made changes in master that allow selection of those islands inside blender. Leaving the exporter part to Bastien, though from brief look it seems as if this might not be possible and may need to be handled from importer side.

Antony Riakiotakis (psy-fi) closed this task as Resolved.EditedApr 9 2015, 4:35 PM

Alright, from what I can see FBX is just dump of per-face UV layer. This means that the issue is in the importer, not the exporter.

We had some small discussion with Bastien, looking if we can at least support custom seams, but looks like this is not possible either. I'm sorry but looks like you'll have to poke the teams of other software for proper support of such a feature.

If it's possible to export the same UV setup from another application and have Mudbox identify it as separate islands, then maybe we could mimic what the other software does, but from my understanding this is not possible.

Closing again.

It's just the behavior of the UV Image Editor selection tool that makes it seem as if the islands are attached.

By using face selection mode in the 3D Viewport and by pressing the 'l' key, you can select the individual islands and move them independently in the UV Image Editor.

It does feel like a flaw in the tool's behavior since it does seem as if some auto-merge function was being applied to the edges of the islands. It seems inconsistent that the interior faces are not moved simultaneously since that would make the grab tool useful for editing multiple islands at the same time, however, that's an implementation limit and not a bug.

The exact value for moving the right island over to the left Island is -160 pixels. Maybe the artifacts you are seeing are caused by your use of snapping tool instead of the precise value.
If you are off by even a pixel or two, it may be difficult to notice in the UV Image Editor but it would almost certainly cause artifacts along the seams when the model is textured and lit using normal maps.

I tested UE4 and the model looks fine. I also transferred the model and textures over to a stand-alone GLSL program and it look fine as well.

You are welcome to post problems that you have on Blender StackExchange, usually you don't have to wait long before receiving and answer and it's good to have feedback from more experienced artists when you run into problems like this.

If you do post a question on Blender-SE which turns out to be a bug, the people there will close the question and refer you here so you can file a report. Otherwise the bug-tracker can become overwhelmed with red-herrings. :)

http://blender.stackexchange.com/questions/

I don't see why the extra comments, the selection bug has been fixed in master.

Also, just a note selecting UV islands will not always work in 3D view - seams are not always present on the model, or seams may be different than what user has made on 3D view. In any case it works now.

Also, this is not strictly about unreal - user mentions marmoset and it may well be cooperation between other -editing- software that lose the island information. Final display will of course always be the same.

Sorry to bug you again about this, but I still experience a strange behavior of blender. If I snap a vertex of one island to the corresponding vertex on an other island (in 3D space, they belong to the same vertex), Blender welds them together. In that case it's not possible to select the islands separately using ctrl+L or island selection, no matter which sticky selection mode is used.
Is this a feature and if so, could it be turned off? If I deliberately wanted to merge two UV-islands I would use the weld tool.

To clarify my point, I attached a small example file:

Blender Version: 8be4d76

@Campbell Barton (campbellbarton), this is the bug I was mentioning on that comment.

Campbell Barton (campbellbarton) changed the task status from Resolved to Invalid.Jul 13 2017, 6:28 AM

Reverted this change since it causes T50970

Checking the report again and in overlapping the islands and you're in fact making 2x islands into one.
Since the UV's and vertices are connected.

Select linked operator can be made more advanced to handle cases like this. See: D2567