Page MenuHome

Appending an object that is part of a linked group
Closed, ArchivedPublic

Description

System Information
Win7; GTX 560 display; GTX 970 render

Blender Version
Broken: 2.74 official
Worked: (optional)

Short description of error
Blender behaves weirdly when appending objects that are part of already linked group.

Exact steps for others to reproduce the error
Open Blender, Add a Cube and a Monkey, group them together and save the file as Source.blend
Make a new file called Target.blend and link the group from Source.blend
Append an object Suzanne from the Source.blend - now it is not actually appended but it is linked instead (is this also a bug?)
Select the appended Suzanne (the one that is not in the linked group) and in object properties make the object datablock local.
Now you can move the appended Suzanne but the linked one moves as well (even that the Suzanne in the Source.blend does not move)
To solve the problem you need to save the file and revert it.

Details

Type
To Do

Event Timeline

Marek Moravec (marek) set Type to Bug.
Marek Moravec (marek) created this task.
Marek Moravec (marek) raised the priority of this task from to Needs Triage by Developer.
Sergey Sharybin (sergey) triaged this task as Normal priority.

@Campbell Barton (campbellbarton), i'm not really sure how such situations were intended to behave. Do you have ideas here?

I think that it is a problem that it is linked though Suzanne was appended.

It works definitely if I reverse order to carry out.

The first issue is known, (commented in the code at least), noted rBM590, see note at: https://www.blender.org/manual/data_system/linked_libraries.html

See rB76420c2f

The second issue with making local an object used in a linked group, Im quite sure we ran into before... of course its possible to solve but quite involved.

  • Detect all references from library data.
  • Detect all references from linked data.
  • Make a local duplicate, and point all local references to the newly created local data.

... even then, duplicating the data could run into problems

Added to TODO,
http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Import_Export#Blender_files_and_Library_linking

Bastien Montagne (mont29) closed this task as Archived.Nov 26 2015, 8:31 AM
Bastien Montagne (mont29) claimed this task.

No real point in keeping this open once TODO is added to our list as linked by Campbell, archiving.