Page MenuHome

AL lib: UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead
Closed, ArchivedPublic

Description

AL lib: UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead
This error pops up when i try to start the program.
It worked fine on a laptop and windows 7 but now i got a new pc with win 8.1 and i
need blender to continue learning so thanx for helping me out if you know anything about this...

And sorry i didn't reply at the previous task i was kinda busy, never did this before and thought like the
other forums it would take weeks and months before someone replies.. :s

Details

Type
Bug

Event Timeline

btw my drivers are up to date and i've tried it in compability modes from Windos SP1 to Windows 8.1 but it didn't worked either...

Julian Eisel (Severin) closed this task as Archived.Apr 16 2015, 5:32 PM

I don't see a need to reopen this? As we said in T44286, the printed error seems to be just a warning that it falls back to the 48000hz, but everything should work fine with this (and you confirmed that). So so far I still don't see a bug here, such a warning isn't really a big deal, it's just additional information mainly for developers.

So let's handle this as closed as well? We can reopen if you find real issues that appears to come from the 48000hz mode. But thanks for reporting nevertheless :)

it is a printed error ok but i cant acces blender?
How do i enter the right mode because by knowing its a fallback to 48000hz i still cant use blender...

:( plz dont say i need to recreate this thing again to solve this...

Julian Eisel (Severin) reopened this task as Open.Apr 16 2015, 7:33 PM

Aaargh, you never said that it crashes on startup... that's the most important point :P

Reopening

and no, nothing works fine thats the problem right here...
Really if it was something common i just googled it but it is rare to find in google and all i
got about this are solutions for ubuntu and linux.

I don't think the warning that is printed to the console is because of the crash, crashes on startup can happen because of many reasons so let's check a few things:

  • Ensure your GPU driver supports at least OpenGL 1.4
  • Ensure you have installed MSVC2013 redistributable package (http://www.microsoft.com/en-us/download/details.aspx?id=40784)
  • Try to disable any running antivirus
  • Ensure you have no python executable available in your %path% environment variables
  • Try the latest build from our buildbot.
  • Try to start Blender in factory settings (--factory-startup commandline option - this will show whether this is a userpref or add-on issue or not).
  • Try to place this dll next to your blender.exe (software OGL, will be slow, but will show whether this is a driver issue or not).

you have seven points right there i didn't checkt out or even ever heard of..
So great job B) i have now 7 options to check brb

ok i tried a few things..
My GPU supports OpenGL 1.4, i have the latest MSVC2013 package and
i tried your buildbot thingy but no results.

Then i used your dll and that worked, do you mean by slow the startup or the whole proces?
It works and thats a victory on those bugs and errors itself.

What is your thought about it now?
And could i possibly remove the lag by the dll?

The .dll is just a way to test if the issue likely in Blender's code or a graphics driver issue. That it works shows us that it might be a driver bug. Could you give us the exact name of the graphics card and the driver version you use?

And yes, Blender is slower using the dll entirely, not only on startup

btw its a clean installation so factory settings aren't the problem and antivirus ins't the problem too.

ok srry i get your comment when i comment something im looking it up now

driver version: 14.501.1003.0 (not sure if this is it)
Graphics card: AMD Radeon(TM) R7 Graphics (intergrated in AMD A10)

Again, I don't think the warning and the crash are connected, the warning should be completely harmless.

@tibo van gindertaelen (CoreX), hmm, you could try if an old driver or the beta driver resolves it

i agree but this warning were talking about holds me back from entering blender :/

Not sure what you mean... Is that a popup window or something? Mind making a screenshot?

i need to get i setted to 44100hz so i can actually enter blender but i have no idea at all what this means and so does google!

ok wait and again srry i cant see your comment before sending mine.. :3

Ok guys now im freakin out..if i run it as an admin it works perfect...is this a glitch or what?

that message pops up and then it closes and the blender screen comes up... #_#

Julian Eisel (Severin) closed this task as Archived.EditedApr 16 2015, 9:33 PM

I can't tell you much about why this is needed or about Window's security management, but at least you now know how to start it :) So as I said, the message that is shown in the console and the crash have nothing to do with each other as it seems.

Anyway, closing this as "Archived" since it doesn't seem as we have a bug in Blender here.

But thanks for the report nevertheless :)

Erik (Chuppix) added a subscriber: Erik (Chuppix).EditedMar 23 2016, 7:10 PM

i have the same problem...
i removed the python.exe but still
i did everything as you said/suggested
everything is good
i tried running in administrator mode and still
but i didnt change my audio defaults because i dont know how :/

i have the same problem...
i removed the python.exe but still
i did everything as you said/suggested
everything is good
i tried running in administrator mode and still
but i didnt change my audio defaults because i dont know how :/

I have the Same problem >:(

Have the same problem, after runing once, instal or from zip package I cant start it again :(.
My way around that is simply remove the Blender catalogue and unzip new once after closing Blender.

Same SLI 2xATI R9-200series and windows 10.

But i can say that this in not the ATI problem becouse in home i have same GPU (one) windows 7 and i do not have the problem.

I notice that after closing Blender it saves some kernel files, config etc and in Windows 10 you have f%^&k up user/admin privileges so after closing, blender can't read files it create ;(. Same problem in previous work after changing only user name (no cleaning simply change one worker to another) I have the same problem .

Startup crashes can happen for many reasons, some similarities to this report don't have to mean anything, they are most likely unrelated. And let me also repeat myself: The "AL lib: UpdateDeviceParams: Failed to set 44100hz, got 48000hz instead" info is completely harmless and doesn't have anything to do with the crashes you're experiencing (except if audio drivers or OpenAL are buggy but that's really unlikely the issue).

Anyway, please create new reports for these startup crashes, we have to investigate them separately.

I think some guys above to referencing this page https://en.wikipedia.org/wiki/List_of_AMD_graphics_processing_units for more details of your gpu.
only AMD HD 7xxx and above have API compliance opencl support and rank < 2011 have no opencl support. This is the reasons for blender error like that.
And now is https://www.blender.org/manual/render/cycles/features.html for referencing about nvidia gpus and amd gpus. Hope this help!
Sorry for my bad english.

Blender v2.78 and this happen on win 8.1
Help me please. the black mark is very annoying.

What can I do to avoid this? It's very annoying. I keep getting the same and then Blender loads.

Ok, this is still happening for me after installing a new computer.
E.g. 3d max starts, blender doesn't
I managed to get rid of the audio message and it's got nothing to do with the startup stopping(not crashing)
I got now simply a blank console hanging.
win 10
gtx 980Ti + Quadro 4000

The solution for the error/warning outlined in the OP is here:

Open user preferences with Ctrl+Alt+U and go to the System tab.
In the sound settings below, change the sample rate to 48000 kHz and save user settings
Restart Blender

https://blender.stackexchange.com/questions/77857/error-al-lib-updatedeviceparams-failed-to-set-44100hz-got-48000hz-instead-wh

I ran blender and it looks all zoomed in and fuzzy.


The OPENGL32 thingy works but it slows Blender down a lot. I've tried changing the Audio settings, but it didn't work. Is there a way to fix the resolution bug and not have slow FPS?

I have the same problem and I tried everything! (I deleted python, I used blender builder and more)
Nothing is happening please help me guys!