Why the lamp hidden cause noise ?
Closed, InvalidPublic

Description

System Information
win 7 + gtx970

Blender Version
Broken: 2,74 165598e 32bit + 64bit

Short description of error
In cycles
In complicated scenes with a large number of lights the darkness of the scene despite brightening light and make noise.
All Bug see in Hidden lamps cause noise and darkening the scene.
A big nuisance.

Exact steps for others to reproduce the error

You render my file LAMP+SUN-bug.blend with there are lights and no lights in Cube ( lamps in layer nr10 ):

.

Details

Type
Bug
Bastien Montagne (mont29) triaged this task as "Incomplete" priority.May 8 2015, 10:10 AM

I do not understand your issue here? Obviously, if you remove a lamp from the render (e.g. by hiding its layer), the scene will be darker…

Thomas Dinges (dingto) closed this task as "Invalid".EditedMay 8 2015, 10:13 AM
Thomas Dinges (dingto) claimed this task.

With Path tracing, we sample 1 light at random per sample/bounce.
By adding more lights (even if hidden), the sun lamp will not be sampled on every bounce, but some of the other ones will be chosen, leading to fewer samples for the Sun.

That is not a bug, but the way the code works now. We can make it smarter probably, but that's a possible optimization.
As a workaround, you can use the "Branched Path" integrator, with Sample all Lights enabled.

In my file "Lamps are closed box" and So they can not influence what is outside, it seems obvious .
But if we assume that the lamp always affects the scene this means that the lamps cast a black shadow box outside.

To clarify:

Imagine a iteration loop, you run the loop 5 times.
When you have only 1 sun lamp, the sun lamp will be obviously sampled 5 times.
But once you add more lamps, the sun might only be sampled once, and the other lamps get the other 4 samples.

That's why the shadow from the sun is noisier.

ok, Thomas realized, I understand that as a black lamp shade noise :)

In my opinion , this information should be clearly described traits typical noise .
Currently I'm doing a scene at night spend a lot of time to arrive at the truth ,
This could be important for others and may be an attempt to remove the "black noise from lamps" like the typical "light noise reduction".

regards

The matter is not so simple,
If you disable Node link - Emissions hung from lamp Output - black noise still remained ,
It 's not a matter Sampled.

Problem is a "Lamp Object" causes black noise , not its Emissions.
because this is an bug . Therefore Lightpath does not work for such Lamp .

ps. Thomas e.g. 5 samples should not be if there is no Emissions.

It might be good to remove lamps with empty shader networks, there's already some code like that for ignoring the background. This will not solve the problem in the original report though.

That's really a classic rendering problem with no easy solution, and for that reason there are two different types of integrators, and which one works best depends on the scene. For this one branched path tracing will work best. But that does not mean there is a bug in regular path tracing, which will work better in some other scenes with many lights. The issue is it's not possible to discard those hidden lamps quickly, it requires tracing a shadow ray which is expensive. Sometimes that's worth the noise reduction, sometimes it makes the render so much slower that it's not worth it, and it's not really possible to figure that out automatically a priori.

Also, please leave the decision to close the report or not up to developers, they can always reopen it if they agree with you.

I think that for users blender is the most important preparation renderinu predictability ,
Ot unpredictable is that the increase in light quantity of lamps is the cause of darkness :(
Such a change is only permitted if everyone knows the truth about the mechanism .

I wonder if other sources of light, and its lamp will be a LighPath fix " only dark noise ' ( outside the box ) ?

Brecht Van Lommel (brecht) closed this task as "Invalid".May 8 2015, 7:31 PM

Actually there seem to be two issues here. One is the increased noise, which is not a bug as I explained above, just use the branched path tracer for best results.

The second is that the images actually converge to different results. The cause of that is the Clamp option that is used here. It's unfortunate that this option can change the look of the render when making such seemingly unrelated changes, but it's not actually a bug that can be fixed. Clamp is sort of a last resort to reduce noise, and should ideally only be set to high values like e.g. 100.0, 3.0 and 4.0 or really low and will be totally physically unrealistic, so use that at your own risk.

All other renderers implementing clamp options actually have the same issue in one way or another, it biases the result, and sometimes quite a lot like here if it's set to a low value.

Arkadiusz Zubowicz (studioa) changed the task status from "Invalid" to "Resolved".May 8 2015, 9:51 PM

Thank you for your help, I understood ,
I think the matter has been resolved by setting ' Branched Path Tracing "
what remained of law gtx970 hardware bug but a new thread

Hi,
I'm sorry that I'm stubborn , but I found the source of problems that only a programmer can fix .
Problem = Disconnecting Emisson of LampOutput does not disable the Lamp from the calculation.

Sample in file .blend
step 1. F12 -> view-1-render in 50samples
step 2. Turn off the Layers 11,12,13,14
step 3. F12 -> render -view-render and compare results view-1

Disconnecting Emisson of LampOutput does not disable the Lamp from the calculation.
Emisson disconnection must cause the disconnection of the lamp from the calculations , as is the exclusion of Layers .
I think also when you turn on the black lights and power of 0 also should be disconnected lamps .

ps . Cycles behavior causes problems and confusion action Cycles by users.
At the same time it seems that there should not be a problem disable the "black noise" which depends on the number of lamps,
or the ability to track his in "Lightpath" "Is NoiseLamp " :)

Julian Eisel (Severin) closed this task as "Invalid".Jun 22 2015, 1:32 AM

@Arkadiusz Zubowicz (studioa), as Brecht already said, please leave bug triaging (incl. opening/closing) to us, it's a crucial part of our tracker management.
If you don't get a reply here, you can try your luck using the Cycles mailing-list or in IRC #blendercoders.

So thanks for the report, but for now we keep this closed.

@Julian Eisel (Severin) I'm sorry for the unnecessary post , forgive
I am fledgling bugtacker user :)

@Arkadiusz Zubowicz (studioa), this is a nice optimization to do in general, but strictly speaking it's not in the scope of the bug tracker. Improvements are being handled separately, so bugs tracker stays more manageable by handful of developers.

Things are a bit crazy in the studio atm, but during next days i'll hopefully have time to implement the optimization. So don't worry, we all are wanting to make blender even more awesome, just give us a bit of time :)