Page MenuHome

viewport render in broken with border render activated
Closed, ResolvedPublic

Description

System Information
ubuntu 14.04, 630GT, 4930k

Blender Version
Broken: master

Short description of error

viewport render is broken with border render activated (not f12 render)
also happens with view render border

Exact steps for others to reproduce the error

open the blend file
active viewport render
disable/enable border render (dimensions panel)

Event Timeline

Ronny G (nutel) set Type to Bug.
Ronny G (nutel) added a subscriber: Ronny G (nutel).
Ronny G (nutel) created this task.
Ronny G (nutel) raised the priority of this task from to Needs Triage by Developer.

ubuntu 64 bits 14.04, blender 2.74.5 hash 8fb9e14. titan black nvidia driver 349.16

I cannot reproduce. Disabling/enabling render border works, here.
It works from dimension panel, from View panel of N column.
With shortcuts (shift B, ctrl B, ctrl alt B), no problem, too.

Do you have an addon enabled ? can you precise hash and driver ?

hash is the same: 8fb9e14
driver version: 331.113
no addons (factory reset)
video: http://youtu.be/BcpYJxxmHYg

Odd, I cannot reproduce the issue here either… Assigning to Antony since you claim bug appears after one of his commits, but if we cannot reproduce the issue it may be hard to fix it.

Bastien Montagne (mont29) triaged this task as Normal priority.May 15 2015, 11:44 AM

What do you use to render? Do you use multiple GPUs?

no gpu rendering here just cpu

found the "solution" if i enable WITH_OPENCOLORIO it works... strange

Reproduced this problem with no ocio, added an inline comment with possible fix here: rB4fc318811

The suggested fix looks good to me, I think you can go ahead and commit this.