Page MenuHome

Rigidbody simulation - flip object just at the simulation's beginning
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card
MacOsX 10.9.5
NVidia GeForce GT 750M 1024 MB

Blender Version
Broken: 2.73a bbf09d9

Short description of error
Inside the blend there is a plane to simulate the floor and an object that when the physics simulate the rigid body, it automatically flips the object and the simulates the rigidbody physics. What this object is flipped at the beginning?

Exact steps for others to reproduce the error
Just press shift+a-key to simulate physics.

Based on a (as simple as possible) attached .blend file with minimum amount of steps

Details

Type
Bug

Event Timeline

Sergi Grau (sergi_grau) raised the priority of this task from to Needs Triage by Developer.
Sergi Grau (sergi_grau) updated the task description. (Show Details)
Sergi Grau (sergi_grau) set Type to Bug.

Can confirm the 'flip', not quite sure why it’s happening, Sergej maybe you have idea?

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Normal.May 15 2015, 9:25 PM

The flip happens because the object has negative scale on the z axis.

We could try to work around this but scaling rigid bodies has other problems and should be better avoided imo, so I'm not sure if it's worth it.

That's true!

Thank you very much.

Sergi

Bastien Montagne (mont29) closed this task as Archived.May 16 2015, 7:11 PM

We can close it as known limitation then. :)