Page MenuHome

User can not hear sound when drilled into a meta strip in the VSE
Closed, ArchivedPublic

Description

System Information
Everything - it works the same on all machines

Blender Version
Broken: forever
Worked: (never - it's sort of a feature request)

Short description of error
User can not hear sound when drilled into a meta strip in the VSE.

Exact steps for others to reproduce the error

  1. Open example Blend{F178770}
  2. Drill into meta strip in VSE (tab)
  3. Note there is no way to hear the sound from within the metastrip
  4. Note it would be nice to have a way to hear sound from within the metastrip (maybe ability to mark a sound file or metastrip of sound files as the "Master sounds" and a checkbox to "Play master sound at all times"

Details

Type
To Do

Event Timeline

Sean Olson (liquidape) updated the task description. (Show Details)
Sean Olson (liquidape) raised the priority of this task from to Needs Triage by Developer.
Sean Olson (liquidape) set Type to Bug.

Thanks for the report, but there is no bug here, it works as expected. This sounds more like feature request - which are not allowed on the tracker. Please use forums or bf-funboard ML for that.

So, looked into it and making this work is quite simple even, but since it's enforced centrally looks like it's so by design, so I would like feedback to make sure this is intended to work as you want.

For me it makes sense as well to not mute sound - sound is not the same as picture, but there might be non - apparent use cases here. I think the most common one would be to have a metastrip of sounds and use it as an easy way to mute all other channels. Since blender does not differentiate between image and sound metastrip though, this quickly becomes a problem. A solo option per strip can solve this but it's not that usual. In any case, we need more people to make the decision.

I don't think that it should behave in this way either

OK so it's three of us. Now we need to make sure that most users are OK with this too. Or I can play dictator of sequencer, commit the change and just follow any screams when the time comes.

I would do it, but not in bug fix period. There is not enough time to gather feedback and I'd rather have the current state in release (with just 3 known screams so far) rather than a new state with an unknown number of screams - may be less than 3 but I'm not risking it.

You can land it into gooseberry and see what people around the studio think. I dont see any reason on why this is like this

Bastien Montagne (mont29) triaged this task as Normal priority.May 26 2015, 3:45 PM
Bastien Montagne (mont29) changed Type from Bug to To Do.
Richard Antalik (ISS) closed this task as Archived.Feb 19 2019, 8:58 PM
Richard Antalik (ISS) claimed this task.

I can imagine supporting this by:

  • introducing concept of tracks as a 1D component of timeline. This would be in compliance with OTIO model.
  • using advanced automation tools. I guess nodes is a way to go

With these words, I am closing this task