Page MenuHome

Cycles vieport - Transparency does not work in Material view.
Closed, ArchivedPublic

Description

System Information
Win7 64bit
GTX 560 monitors
GTX 970 rendering

Blender Version
Broken: 2.74 Official 64bit
Worked: (optional)

Short description of error
Transparency does not work in material view. The only way I found to make it work is to switch to Blender Game renderer and change the parameter Alpha Blend from Opaque to Alpha Blend and than switch back to Cycles renderer. The problem is that the object behind the transparent object are not visible unless the object is selected with RMB. See the attached blend:

Exact steps for others to reproduce the error
Open the Blend file - you can see through the monkey and whole cube is visible.
Deselect all (A) - you can see through the monkey bet the cube behind the monkey is invisible.

Details

Type
Bug

Event Timeline

Marek Moravec (marek) set Type to Bug.
Marek Moravec (marek) created this task.
Marek Moravec (marek) raised the priority of this task from to Needs Triage by Developer.

Im pretty sure this is an known issue a will be fixed with the opengl update am I correct?

Sergey Sharybin (sergey) closed this task as Archived.
Sergey Sharybin (sergey) claimed this task.

Transparency is viewport is not really correct because it doesn't sort faces by the depth, which causes wrong shading. Solving this is possible, but it's quite tricky to do without slowing viewport down, also better to happen after viewport code upgrade (which is currently happening in the branch).

So thanks for the report, but it's known TODO.