Page MenuHome

Volumetic Emission shader disappear in Render
Closed, ArchivedPublic

Description

System Information
Operating system and graphics card
AMD Phenom II X6 1055T 2,80 Ghz
12 GB Ram

GTX 660

Blender Version
Broken: (example: 2.69.7 4b206af, see splash screen)
Worked: 2.74.5

Short description of error
Volumetic Emission shader disappear in Render when rendert with an Alpha
it works in the viewport
an in the Render the Volumetic Emission is in the Color Chanel but not in the Alpha Chanal
Witch mean if the Volumetic Emission Objekt Bot an Objekt in the Bake witch is casing an Alpha it is in The Render aserwise not

Exact steps for others to reproduce the error
Based on a (as simple as possible) attached .blend file with minimum amount of steps

Details

Type
Bug

Event Timeline

Christoph Pöhler (dracio) claimed this task.
Christoph Pöhler (dracio) raised the priority of this task from to Needs Triage by Developer.
Christoph Pöhler (dracio) updated the task description. (Show Details)

Emission is not supposed to affect the alpha channel, for that you need to add absorption. For most types of volumes you want to add emission and at least a little absorption, which would avoid the issue.

The problem here is in display, it's converting a premultiplied alpha image to 8 bit unpremultiplied. But unpremultiplied can't represent emission without absorption.

I just wanted to report the same thing...
This is pretty weird, because it works in the viewport.
And it is not true, that it is completely invisible, there are some strange artifacts around the mesh border.

Sergey Sharybin (sergey) closed this task as Archived.Jun 2 2015, 8:25 AM
Sergey Sharybin (sergey) claimed this task.

This is a known behavior of color pipeline which was reported here several times already. The issue is a bit tricky to solve without breaking someone's use of image editor, but it's surely in our TODO list of things to solve.

So thanks for the report, but archiving it as a TODO now.