Page MenuHome

Geforce TitanX SSS material on GPU renders slow
Closed, ArchivedPublic

Description

System Information
Win8 x64
Geforce TitanX

Blender Version
Broken: 2.74 2015-05-29 (buildbot build) hash:1a0c961
Worked: (optional)

Short description of error
SSS rendering on the TitanX is slow, for me it's slower than CPU.
I've got contacted on BA.org by a french user having a TitanX and a Titan Black. On his system the Titan Black is faster than the TitanX on SSS rendering.

I mentioned it because he is also eager to see if there's a solution, and if it could be of any assistance to mention that the Titan Black (Kepler) is faster rendering SSS
than the Titan X (Maxwell) card.

Correct me if I am wrong but it could be that they are using different cuda kernels. sm_50 and sm_52 are for maxwell cards, TitanBlack being kepler is it using sm_35?
anyway happy if someone could investigate if there is a solution.

Exact steps for others to reproduce the error
Just try and render a scene with a SSS material present, on a system with TitanX.
I added a simple .blend scene and two screenshots.


Details

Type
Bug

Event Timeline

I don't know if the maxwell card has to be faster here then the kepler card.

But I really think there is a high probability we could improve performance on maxwell in general.

Intel i7-3820 3.6Ghz, Quad core stuff.
Usually my CPU doesn't outperform my GPUs (have two cards)
here's another test render comparison with my standard shader, regarding CPU vs GPU performance on my machine.

CPU is 70s

GPU is 9s

So it's weird to see my CPU outperform GPU on SSS, when usually it's so much faster. Gonna check with the french blender user if he can submit/contribute GPU renders Titan Black vs Titan X.

SSS is really really not nice on GPU's but that is to be expected. This is more about why the maxwell card performs less well then one would expect.

For that problem I expect some of the kepler specific hacks might actually improve performance for the SSS case. But I need tot run tests to see what is really going on.

Maxwell has performed good for me, except SSS. I will try and get some test renders Titan black vs Titan X from the french user.

And if you need me to run tests, I will help out!

Hi all,

Here are my specs :
AMD FMX 9370 - 8 cores - 4.41Ghz
32 GB DDR 3

ASUS GEFORCE TITAN BLACK - 6GB
ASUS GEFORCE TITAN X - 12 GB
Blender 2.74 official release
Nvidia Drivers : 352.86

Here are the result based on Martin Blend.File.
Titan X run 5 time slower than Titan Black.

TITAN X

TITAN BLACK


This performance gap append on EVERY SHADERS, as soon as Experimental mode is enabled.
And the performance loss is more important on TITAN X than BLACK. Test made with same file, glass shader with samples bumped to 500.

TITAN X

TITAN BLACK

I hope it will help and you can improve Titan X performances.
I'm really not a good technician about these technologies... I just can say that Titan X is supposed to be faster as it has more CUDA cores and is not -_-°

BTW....

If you need any other further tests, do not hesitate I'll be glad to perform them.

Ah yeah, can confirm that, from 8.5s to 28.5s to render a test scene when going from supported to experimental.

Bastien Montagne (mont29) lowered the priority of this task from Needs Triage by Developer to Normal.Jun 1 2015, 9:33 PM
Thomas Dinges (dingto) closed this task as Archived.Jun 2 2015, 4:04 PM

The Experimental kernel was added *because* of the increased memory usage and performance drop with enabled SSS. We are aware of that and hope to improve that in the future (CUDA kernel split should fix these issues).

Closing as Archived, as this is a ToDo.

Hi Everyone,

Did you have any other information about this fix?
Do you have any idea when it could be fixed?

Thanks for your interest and B.REGARDS

Hello everyone,

Discovering this thread as I just got a Titan X and discovering this problem with "experimental" render enable (using SSS).

I tried on 2.75 and 2.76 and the problem is the same...

My specs:
Processor I7 4770
MB: Asus Z87 WS
GC : Gigabyte GTX titan X

WIndows 8.1

Very frustrating as I'm rendering characters so using SSS all the time...
Arghh...

Hope you guys will be able to fix this soon....

Thanks a lot for your good work and dedication to this great software.

Alex

I got 2 cards, GTX 970 and GTX 780, testing with experimental mode with a SSS material

GTX 780 = 8 seconds
GTX 970 = 30 seconds

the same scene without SSS "just diffuse"
GTX 780 = 4 seconds
GTX 970 = 6 seconds

something is wrong with Maxwell kernel settings "probably registers"

Hello,

I wanted to have some news about this issue...
Can I help in any way?

Testing scenes or things like this?

Thanks for your work and your feedbacks.

Alex