Page MenuHome

Add > Shader menu shortcut inconsistencies
Closed, ResolvedPublic

Description

System Information
Mac OS X, NVIDIA GeForce 320M

Blender Version
Broken: 2.74

The menu shortcuts for adding Shaders are different, depending on where you add them from.

Exact steps for others to reproduce the error

  1. Set the render engine to Cycles.
  2. In the Node Editor, after creating a material, press Shift A, H, G and a Glossy Shader will be added (G for Glossy)
  3. In the Materials tab, under the Surface section, click the Surface selector and press G - a Glass Shader will be added (G for Glass)

This is undesirable because the user must memorize two sets of shortcuts for what is essentially the same menu.
Now, some people may say "just use the Node Wrangler add-on" or "this is not a bug", but I think it is a usability concern because the result is that the built-in shortcuts are much less effective for this feature. And since when we construct materials we need to access the Add > Shader menu very often, I think it's at least worth bringing attention to.

In my case I decided to memorize only the shortcuts from the Node Editor and simply not use the keyboard when selecting from the Materials tab, but every time I do use the Materials tab to change the shader in a simple material I wish for a moment that I could use the shortcut I already know.

Apologies in advance for mentioning something that is probably not a bug. I don't know where else I can bring up usability issues to the developers, so I'm posting here. Close or delete this if you think it's not valid. I just offer it for your consideration.

Details

Type
Bug

Event Timeline

Seth L. (quantumanomaly) updated the task description. (Show Details)
Seth L. (quantumanomaly) raised the priority of this task from to Needs Triage by Developer.
Seth L. (quantumanomaly) set Type to Bug.
Bastien Montagne (mont29) closed this task as Resolved.Jun 7 2015, 9:50 AM
Bastien Montagne (mont29) claimed this task.

Think this has already been fixed, here in latest master hitting G gives me glossy BSDF in all cases (note those 'shortcuts' from enum choices are generated automatically, only control we have on those is order of items in said enum). Anyway, please always check with the latest build from our buildbot before making a report.