Page MenuHome

Sculpting with dyntopo "brush detail" crashes Blender.
Closed, ArchivedPublic

Description

System Information
SolydX-64 on Dell Laptop - Latitude D530 onboard video
Intel ® Graphics Media Accelerator X3100

Blender Version
Broken: 2.75 rc1
Worked: well, there's no "brush detail" for dyntopo before this,
but the other dyntopo modes seem to work ok.

Short description of error
Sculpting with dyntopo "brush detail" seems to crash Blender.

Exact steps for others to reproduce the error
Load factory defaults.

Join the main area down
'cuz you don't need animation area down there.

Delete the cube. Create icosphere.

Sculpt mode. Symmetry on or off.

Enable tablet pressure for size.
I have a Wacom Bamboo tablet.

Dyntopo, Brush detail.

Sculpt for a minute or two.

It seems that once the verts get to about
30,000-45,000 or the tris get to about 60,000-90,000
then the processor runs up and Blender hangs.

To exit, I have to bring up the task manager, and kill the process.

Details

Type
Bug

Event Timeline

Eli Innis (Doyousketch2) updated the task description. (Show Details)
Eli Innis (Doyousketch2) raised the priority of this task from to Needs Triage by Developer.
Eli Innis (Doyousketch2) set Type to Bug.
Bastien Montagne (mont29) triaged this task as Needs Information from User priority.Jun 12 2015, 10:11 AM

This sounds like simple hang on big polycount mesh… Your 'GPU' is veryvery low, and for sure won't be able to handle heavy geometry.

You say other brush modes work OK, but did you reach that number of triangles with them?

@Antony Riakiotakis (psy-fi) may have better insight here, too.

It may indeed be due to a faulty GPU driver. Brush detail makes things worse because it can make polycounts explode with small brush sizes leading to driver having an issue catching up (generating too many vertex buffer objects or so). I think it would be nice to clamp the brush detail to the constant detail actually to avoid situations such as these.

It seems that when I use the other dyntopo modes I can easily go over 200k tris with no issues,
450,000 before it slows down. I kept going all the way up to 1.25 mil just to be sure.

The memory use doesn't peak, so that doesn't seem to be an issue.

The funny thing is, when the processor runs up, it seems to hang between 40 and 50%
which I'd think means it's only using up one of the cores on its Core2Duo.

It'll do a similar thing while in the other modes, where it'll pause for a second or so,
as if to recalculate the mesh or something, sorta like when a swap file is being written to.

The thing is, in the other modes it always returns control, so you can get back to sculpting.
Brush detail mode doesn't relinquish control, even if I wait for a few minutes.

I do appreciate the feedback. I listened to what you said,
and did a full system update, to make sure drivers were as good as could be.

It seems to be doing better, so maybe it was as you say.

I notice that if I just do Subdivide edges,
or just do Collapse edges,
then I get a faster response time.

When combined as Subdivide Collapse mode,
that's when it had those little lag moments.
You get smooth sculpts that way tho, so I like 'em both on.

I guess my recommendation for the Brush detail would be that if it's already known
that setting this slider too low brings the poly count up high real quick,
and it's also known that too high of a poly count can crash Blender,
then it might do well to set the default to something a bit safer, say 35%

Maybe a warning if you drag it down to less than 15%
I'll play around with it some more and let you know if it misbehaves.

Thanks tremendously for your efforts with Blender.

Bastien Montagne (mont29) lowered the priority of this task from Needs Information from User to Confirmed, Low.Jun 19 2015, 9:49 AM

any reason to have this open if it is a old hardware issue?

Sergey Sharybin (sergey) closed this task as Archived.Feb 2 2016, 4:15 PM
Sergey Sharybin (sergey) claimed this task.

@Eli Innis (Doyousketch2), it's not just about number of triangles, but also number of GPU buffers which isn't really linearly depending on the number of triangles.

Surely it's possible to support older hardware, but that's not really effective time investment. So thanks for the report, but closing it now.