Page MenuHome

Mac OSX notifications on multiple Blender instances
Closed, ResolvedPublic

Description

When opening 2 or more instances of Blender on OSX, at end of any operation connected to the Notification Center (render, comp, bake), a notification is displayed even if Blender is in the foreground.

Details

Type
Bug

Event Timeline

Francesco Siddi (fsiddi) set Type to Bug.
Francesco Siddi (fsiddi) created this task.
Francesco Siddi (fsiddi) raised the priority of this task from to Needs Triage by Developer.

The thing is, we don't check for foreground/background processes in our side, seems it's all being decided by the notification center itself.

@jens verwiebe (jensverwiebe) do you have any inputs here?

Assigning to Martijn since he's kinda maintaining OSX now. But i'm open for helping him with investigation.

Sergey Sharybin (sergey) triaged this task as Normal priority.Jun 15 2015, 11:59 AM

All is like it should be !

If you have 2 instances of blender open and the rendering instance ! is in foreground, notification will
not show up. I will only occure if the rendering instance is in bg. So what ?

I propose to reject this issue.

Jens

My problem is that the the notification shows up for the fg blender.

  • Open Blender
  • Open another Blender on top and press F12
  • Notification appears

On your setup this does not happen?

Nope
This is how notifications work normally: they inform you about bg tasks.
I tried different instancing too: 2 times started blender from binary in dock - strted blender 2.74 and 2.75rc -> always correct behaviour
Perhaps check your notification center for settings, but 'am not aware you could affect this.

Or it is a bug in your OSX version ?

Jens

I can't reproduce this bug either, Blender 2.76-rc2 on OS X 10.10.5.

So either it's fixed already, or we need details about the exact Blender / OS X version and how you open Blender. Is this using two different Blender applications or a single application, are they opened by from the dock, finder, terminal, .. ?

Francesco Siddi (fsiddi) closed this task as Resolved.EditedSep 30 2015, 1:30 AM

Hey there, thanks for looking into this.
I just checked again and it seems fixed!
For the record, I was launching Blender via the terminal. I'm closing the issue, unless there is a more formal procedure to follow.