Page MenuHome

Hair system and modifier stack order bug
Closed, ArchivedPublic

Description

Hi,

When we have a hair system and after we add a subdiv modifier, The hair system dosn't use the subdiv, even when the "use modifier stack" is enable.
To use the subdiv for the hair, the subdiv modifer must be under the hair system in the modifier stack.

If we move the subdiv modifier under the hair system, we have this bug.

http://www.pitiwazou.com/wp-content/uploads/2015/06/hair_bug.gif

Details

Type
Bug

Event Timeline

cédric lepiller (pitiwazou) created this task.
cédric lepiller (pitiwazou) raised the priority of this task from to Needs Triage by Developer.

could you attach the file? Did you test on the goosberry build (new hair system). If it works there, chances are it will be fixed when new hair system is commited to master.

There is the scene, I tested with the last 2.75.1 build 5300345 and a 2.74.5 05c04c24.

https://www.dropbox.com/s/qhfyq2pl9bjezi6/hair_test_002.blend?dl=0

I will test with the last gooseberry.

@mathieu menuet (bliblubli), for the records, there is no "new hair system" in development, it was one of the original goals for gooseberry but they figured out early on that this wouldn't be achievable during the project.

Oh ok, this explain why so many bugs regarding hair and particles are not addressed then. It's better so in the meantime as every fix made in the last versions created a cascade of new bugs. Let's hope we can soon forget this mess.

Arf, so no possibility to fix this bug ?

Sergey Sharybin (sergey) closed this task as Archived.
Sergey Sharybin (sergey) claimed this task.

I don't see a bug here. Modifiers from the stack are being evaluated one by one, and each modifier only knows result from the previous one and the base mesh. Modifiers never predicts the future. This means that "Use Modifier Stack" on hair means that hair will be emitted from mesh which was a result of all modifiers prior to the particle system modifier. If that option is disabled, base mesh is used.

For me it's a bug, even with use modifier stack enabled, it's not working.

It seems, that the hair system is attached to the curent subdivision and if we change this subdivision, it's nor working fine.
It's anormal and if we add a displace, it's not working because we have to change the subdivision.

For me it's impossible to work on a charater who will have some modifications, updates etc
We have to make the hair in last and it's not always possible.

So how can I make my characters on blender with this kind of bugs/behavior ?

If we don't use the modifier stack, we cannot use the subdiv modifier.

In fact, on Blender, if we add a hair system, we have to add a subdiv/multi/displace in first, if we don't, we have this kind of bug.
So impossible to work on a character who will have some modifications, fix etc.

I think Sergey did not understand what was the awaited behavior. It's clearer in your last image that the subdivision messes he hairs. Now that the bug is archived, I think you will have to open a new one. Most of the time they don't read those report anymore.

@mathieu menuet (bliblubli), that's not true, of course we read such comments, we just sometimes forget to answer them since the reports aren't open anymore and because of that, there's no reminder for us.
In those cases it helps to be a bit pushy and ask again if you didn't get an answer a couple of days later, then we get notifications about the report and we're usually reminded to have another look.

It wasn't an attack, just an advice coming from 2 years experience of reporting bugs.

I hope it will be fixed, I'm working on a character and even if I create the subdiv or multi rez first, my hair bug when I change the subdivision. :(

When I add guides in the particle edit mode, I have the bug, when I just add a hair system, it works.

So the problem is with the particle edit and modifier stack.

@mathieu menuet (bliblubli), That's some weird experiment, we've got notifications if activity happens in old bugs and tryign to address them in the same way as new reports. Sometimes we might also indeed misunderstand the bug, but it doesn't mean you need to immediately re-submit it as a new one. Having more complete history of discussion usually helps.

@cédric lepiller (pitiwazou), First of all, you can't really have full power of subsurf modifier -- having different resolution for viewport and render will ruin your day. This is caused by internal limitations of the system and think it's even noted in the tooltip.

This is quite fragile system currently, and prior to supporting such cases we'd better land some more rock-solid base for it. I know you guys wants this to be fixed, but it';s really tricky and think @Lukas Toenne (lukastoenne) will agree it's more a TODO..

Ok, but how can I work on blender if I cannot subdivide my mesh for the final render ?

What is the good way to work with hair ?

Unfortunately there's no really good way to work with hair in it';s current design. General rules are to keep viewport and render subdivisions the same, and don't change it. Caching might help with that, but even that might break. but if you need to change topology/subvdivisions you might try disconnecting hair, make modifications to the mesh and then connect hair back.

That's unfortunate indeed :(
How do you work on gooseberry ?
The mesh is subdivided and you animate it with the subdiv modifier ?

Do the BF plant to work on a new hair system after Goseberry ?
I know it was planned and abandonned.

If it's still planned, I think I could help if it's possible.

Basically we're sticking to the same rules. Changing subdiv level causes issues here as well.

We will for sure kick current system out and write new one instead, but timing is undefined currently. it's not really a simple project, but will happen sooner than later.

Ok, when you will start, I would like to help if it's possible, I'm working on fured characters and I know how works yeti, shave, etc, and if I can help to improve the hair system on Blender in any way, don't hesitate to tell me ;)

For exemple, I made this dog on Maya and Guerilla.

http://www.teojasmin.com/

Right now, I'm working on a cat, with Blender and Guerilla, I use the particle Edit to add Guides, I export thoses guides in Maya And then in Guerilla.
Because I have a 10K pixel picture to make and I have too much bugs on Blender and too less parameters on the fur to make something good.

I would prefer do everything on Blender, but it's impossible right now.