Page MenuHome

CRASH on using high quality DOF setting in camera properties, on OSX10.7
Closed, ArchivedPublic

Description

System Information
iMac 21.5-inch, Mid 2011 OSX 10.7.5 AMD Radeon HD 6770M 512 M

Blender Version
Broken: 2.75a
Worked: (optional)

Short description of error
Blender causes the computer to freeze requiring a power off in order to reboot it as nothing responds except the mouse

Exact steps for others to reproduce the error

  1. Create a cube
  2. Look through camera
  3. Set the viewport DOF to 4
  4. Enable High quality viewport DOF
  5. Crash

Details

Type
Bug

Event Timeline

Samir Osman (Samirosman) set Type to Bug.
Samir Osman (Samirosman) created this task.
Samir Osman (Samirosman) raised the priority of this task from to Needs Triage by Developer.

Antony, maybe you can check that in studio when you're back? this start to be a bit old system, but should not crash anyway. ;)

Bastien Montagne (mont29) renamed this task from CRASH on using high quality DOF setting in camera properties to CRASH on using high quality DOF setting in camera properties, on OSX10.7.
Bastien Montagne (mont29) triaged this task as Normal priority.

The cause of the crash is timeout in the driver due to too much fill rate. Solution is to clamp the effect radius. I'll fix it once I'm back.

Just wanted to add that I'm seeing this too, even on a top-of-the-line iMac. Had to hard reboot - and I actually wasn't even using "high quality".

@Colin Levy (effstops), I'd be interested to see a scene that has the issue without "high quality"

In my experience this only happens with high quality for the reason mentioned above.

Hey Antony,

This is the file that was giving me trouble. I had checked "high quality" and then I was experiencing laggy behavior - every 10 seconds or so I could click and move stuff around, but I was getting a spinning beach ball - so I unchecked the box. Then I hit the "OpenGL render active viewport" button in the viewer.

I haven't had a chance to return to that machine and see if this is reproducible, but in the meantime here's the file I was in. Let me know if the packing didn't work; it was referencing some a linked rig + set:

https://www.dropbox.com/s/v7gttc9fwgef6ny/11L-1_PostVis2_packed.blend.zip?dl=0

Hope this helps!

--C

Brecht Van Lommel (brecht) closed this task as Archived.
Brecht Van Lommel (brecht) claimed this task.

Archiving old report, this macOS version is no longer supported and DoF in 2.8 is different.