Page MenuHome

grouping texture nodes can change the range of values coming from the coordinates input
Closed, ArchivedPublic

Description

System Information
Linux bubastis 3.18.12-gentoo #1 SMP Tue Jun 16 16:26:19 EDT 2015 x86_64 Intel(R) Core(TM) i7-4800MQ CPU @ 2.70GHz GenuineIntel GNU/Linux
01:00.0 VGA compatible controller: NVIDIA Corporation GK107GLM [Quadro K1100M] (rev a1)

Blender Version
Broken: 2.74

A set of texture nodes that include a connection from the Input > Coordinate into a Separate RGBA node provides values that copy the UV coordinates (usually 0..1). If that Separate RGBA node is wrapped in a group, the range of values coming out of the Coordinate changes to -1..1.

Changing it so that the group input is a blue dot instead of a yellow dot works around the problem.

Screenshots and a sample .blend file are at http://blender.stackexchange.com/questions/34894/grouping-texture-nodes-changes-the-coordinate-space?noredirect=1#comment56186_34894

The behavior of the nodes should not change just because they are wrapped in a group. It should remain consistent in all contexts.

Details

Type
Bug

Event Timeline

Robert Forsman (mutantbob) created this task.
Robert Forsman (mutantbob) raised the priority of this task from to Needs Triage by Developer.

posting .blend here for ease

Julian Eisel (Severin) triaged this task as Confirmed, Medium priority.Aug 14 2015, 7:03 PM
Sergey Sharybin (sergey) closed this task as Archived.Aug 26 2015, 1:54 PM

Texture nodes is the most obscure and fragile area of Blender, which currently doesn't have maintainer. I've started looking into re-designing this system some time ago, but project wasn't quite finished still.

I would move the report to the TODO (http://wiki.blender.org/index.php/Dev:2.5/Source/Development/Todo/Render#Node_Textures) for until we'll find someone to pick up development in that area.

So thanks for the report, but archiving as a TODO.