Page MenuHome

Can't open images after Purge Orphan Datablocks. Opened images are not zeroed user.
Closed, ArchivedPublic

Description

System Information
Operating System: Windows 7 Professional 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_gdr.150525-0603)
Processor: AMD FX(tm)-8350 Eight-Core Processor (8 CPUs), ~4.0GHz
Memory: 8192MB RAM
Card name: ASUS R9 280 Series

Blender Version
Broken: 2.75a Hash: c27589e 2015-07-07 14:56 (factory settings)

Short description of error
Images are not zeroed user when opened, having to press the purge button twice to remove them, and when you do, you cant open those images again if you are at the startup file.

The error when trying to reopen the image is:
Cannot read //capture1.png No such file or directory.

Exact steps for others to reproduce the error
-Open Blender
-Goto UV Editing screen
-Open an image at the editor (it doesnt matter if you open it from a file browser)
-Click the X to remove the image from the editor
-Open an outliner in another window
-Purge Orphan Datablocks twice (one to realise the image hasnt any user and another to purge)
-Try to open any image again (it doesnt matter if its the same one) the error will pop.

example video:
https://drive.google.com/file/d/0B1MqW7JZ47SyUWpFZVNTUmVvOWM/view?pli=1

Details

Type
Bug

Event Timeline

Alfonso (Alfonso) updated the task description. (Show Details)
Alfonso (Alfonso) raised the priority of this task from to Needs Triage by Developer.
Alfonso (Alfonso) added a project: BF Blender.
Alfonso (Alfonso) set Type to Bug.
Bastien Montagne (mont29) triaged this task as Needs Information from User priority.Aug 8 2015, 12:00 AM

Cannot reproduce the 'cannot re-open images' part here, please try the latest build from our buildbot.

Can confirm the 'orphaned not updated' part, though… :/

Tried on latest build the link you provided.
Blender-2.75.0-git.44384c6-AMD64.zip
2.75 2015-08-06 15:07 Hash 44384c6

same error cant open image after purge datablocks.

Ive downloaded and unziped the file to my desktop
disabled the antivirus entirely.
open Blender (dont load any file)
and same steps, same error, as the video.

Cannot read "//capture1.png" No such file or directory.

When blender is installed at:
C:\Users\Stark\Desktop\Blender-2.75.0-git.44384c6-AMD64

and the file is at:
C:\capture1.png

I can reproduce this here.
version 2.75 (sub 4), branch b'master', commit date b'2015-08-06' b'15:07', hash b'44384c6', b'Release'

Bastien Montagne (mont29) raised the priority of this task from Needs Information from User to Normal.Aug 8 2015, 8:28 AM

Hrrrm… that seems to be related to windows then…

@Bastien Montagne (mont29):
I add some information.
The same phenomenon occurs in 2.75a(sub0).
This phenomenon does not occur in 2.74 (sub0).
I seemed to load a file normally, but the loaded image is not displayed definitely.

Also cant redo on Linux, but had the issue running Purge Orphans (which needs to run twice to remove the image).

Also tested with rBc62ebefcfcabde0d3df98e65cf8c05e8319cc387 on Windows7 and couldnt redo the bug.

The issue reported can't be reproduced so far, and has been moved to the BF Blender: Unconfirmed project.
If 2 other people aren't able to redo the bug after 2 weeks, it will be closed.

We appreciate the effort that goes into making bug reports, but to be able to fix bugs we have to be able to redo them.
If there is anything you can provide to help others to reproduce the problem, be sure to include it.

Aaron Carlisle (Blendify) closed this task as Archived.Apr 13 2017, 9:27 PM
Aaron Carlisle (Blendify) claimed this task.

Time to close due to no one being able to reproduce the issue.