Page MenuHome

Only "None" OpenSubDiv option in preferences to choose from
Closed, ArchivedPublic

Description

System Information
Linux X64, HD5770, OpenGL core profile version string: 3.3 (Core Profile) Mesa 10.3.2 but Blender system info reports only OpenGL 3.0

Blender Version
Broken: 2.75-44384c6

Short description of error
I don't know if GLSL backends are using something higher than OGL3.3 but there should be atleast CPU and OpenMP backends to choose from.

Details

Type
Bug

Event Timeline

first last (swamp-fish) set Type to Bug.
first last (swamp-fish) created this task.
first last (swamp-fish) raised the priority of this task from to Needs Triage by Developer.

OpenSubdiv uses OpenGL 4 so that might be why. But Sergey know more then I

Julian Eisel (Severin) triaged this task as Normal priority.

@Aaron Carlisle (Blendify), It should be still be possible to choose CPU or OpenMP.

Lets wait on Sergey to investigate.

Here, on Windows 7 Pro 64bit, these are the options available in the OpenSubdiv Compute Type's drop-down menu in Preferences | System for the current Windows 64bit build Hash:44384c6 (by default it's set to None):

I dont have GLSL Transform Feedback

I don't have this list even though in my understanding atleast CPU and OpenMP should be there. You're using Windows and 100% proprietary drivers. For my case(OpenCL probably won't work on pre GCN cards) under Linux there is no point using those as i've tested some time ago, i get overall better experience with OSS ones and performance in Blender is roughly the same. Also i don't understand what does it have to with CPU backends, hopefully its a simple bug.

Bastien Montagne (mont29) raised the priority of this task from Normal to Confirmed, Medium.

I can confirm here that with my default intel 'GPU' and free driver, I have no choice at all in the OSD compute type menu. Once I launch Blender on my nividia GPU (with primusrun), all choices become available…

Even I have coices for Intel card I have 4600

Hi, can reproduce on Elementry Freya 64 with Mesa 3.0.
Intel HD 4400.

Cheers, mib
P. S. Windows 10 is working with Intel driver

Martijn Berger (juicyfruit) closed this task as Invalid.

This is not a bug.

To use opensubdiv you need to be able to both render one or more backends AND support all the following OpenGL extensions:

  • Geometry shader support ( Part of OpenGL 3.2)
  • GL_ARB_gpu_shader5 ( Part of OpenGL 4.0 or an extension )
  • glProgramParameteri, glProgramParameteriEXT, glProgramParameteriARB ( Part of OpenGL 4.1 or as an extention )

Using mesa 10.6 is not expected to work. Mesa 11.x git might work. (based on -> http://mesamatrix.net/ it should work)

Even CPU backends needs OpenGL support, why?
From my point of view it doesn't make much sense. If my card and its driver support those OGL extensions why would i even try CPU backends, why do they exist in the first place?

While compute could happen on CPU you still need to be able to draw stuff in the viewport. It's possible to use approach which is similar to non-opensubdiv case but that's not very efficient.

We probably will look into this later but for now it's not considered a bug.

Thanks for more clear answer.

This comment was removed by first last (swamp-fish).

While compute could happen on CPU you still need to be able to draw stuff in the viewport. It's possible to use approach which is similar to non-opensubdiv case but that's not very efficient.
We probably will look into this later but for now it's not considered a bug.

Maybe you should add in the doc page something about the opengl requirement even for those "CPU"and "OpenMP" backend to avoid further bug reports about those options missing for the opensubdiv, because from an user point of view, it's not obvious having "None" as the only option is not a bug and that high OpenGL is still required as the current doc does not suggest opengl involvement for those backends :

CPU - single threaded CPU implementation. it is mainly useful in cases when GPU compute is possible and threaded CPU option causes artifacts (it is unlikely to happen, but still possible).
OpenMP - multi-threaded CPU implementation. It is similar to threading model of old subsurf code. Use it for maximum performance in cases when GPU compute is not available.

Sergey Sharybin (sergey) closed this task as Archived.Aug 24 2015, 10:23 AM

Docs are still work in progress, but will make sure it's clear what's going on in the final doc version.

Also didn't really meant to re-open the report, it's a TODO so far rather than a bug.

Just for your information, today I installed the latest 64bit zipped version of Blender (Hash: 6a80c2c) and differently from my previous post (see above), now none of the previously listed options is available in the System Preferences, and therefore I cannot enable Use OpenSubdiv in the Subsurf Modifier.

I understand that my graphics card is quite old (GeForce GTS 360M, 1GB, OpenCL 1.1), that's the reason why I use only CPU rendering or external render farms, but I don't understand why those options are now gone, and if the minimum requirements for the graphics card have been raised up to the point that OSD is now excluded from my notebook's capabilities.

Thanks.

@Riccardo Giovanetti (harvester), afraid it's one of those cases when some extension is not reported by driver but actually supported. It's a bit tricky to solve without making someone's else configuration to crash, but will see what we can do.

Thank you Sergey for your kind reply. FYI, the currently installed NVIDIA driver is version 341.81 and if there is any further information I can provide to help you find a fix, please let it me know.

Just a brief update having downloaded the second testbuild and I still have NONE only option in the OpenSubdiv compute's dropdown list, being on CPU only mode (Compute Device is None).

YAFU (YAFU) added a subscriber: YAFU (YAFU).EditedSep 12 2015, 5:28 PM

@Martijn Berger (juicyfruit) wrote:
Using mesa 10.6 is not expected to work. Mesa 11.x git might work. (based on -> http://mesamatrix.net/ it should work)

Hello.
Desktop PC, Kubuntu 15.04 64bit, GTX 960 - 346.59 driver, intel HD 4000, Blender 2.75-26041f9 from buildbot.
Using iGPU as primary display.
I installed Mesa 11.1.0-devel from this PPA:
https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers

CUDA is available under "Compute Device". But only option "None" appears under "OpenSubdiv Compute".
This is what shows glxinfo:
http://www.pasteall.org/61120

Do you mind attaching system-info.txt generated by blender?

The glxinfo doesnt' contain any information about GL_EXT_geometry_shader4 extension which is required for visualizing OpenSubdiv meshes.

Yes, the video driver doesn't support geometry shaders which are required for displaying OpenSubdiv meshes.

In theory we could make drawing code requiring less features from GPU, but in practice it'll mean much much less optimal code which will eliminate benefits of OpenSubdiv.

Hi Sergey, I am not sure if my GPU can support OpenSubDiv and since you mentioned above GL_EXT_geometry_shader4 which apparently seems supported by my graphics card, would you mind checking my system-info.txt report below and let me know about it? Thank you.

http://www.pasteall.org/61124/text

You can consult the actual function which checks for whether GPU draw is allowed or not there https://developer.blender.org/diffusion/B/browse/master/intern/opensubdiv/opensubdiv_capi.cc;45a875fec4c00ccf87c5605d85f004f6dd4be8a0$297

SO currently you need return EXT_geometry_shader4, ARB_gpu_shader5 and ARB_uniform_buffer_object but that might be changing over time.

Thank you Sergey. As far as I can see in my laptop's system-info.txt my graphics card is missing ARB_gpu_shader5 at least. Time to consider buying a new, more modern laptop.